Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Audio problems with WoW


  • Please log in to reply

#1
Samilyn

Samilyn

    New Member

  • Member
  • Pip
  • 2 posts
I think this is the right forum area for this problem.
Alright, here's my problem (it's a weird one, just stick with me): whenever I have the WoW application open, my computer won't play any sound...well, unless you can call static/cd skipping sound. It used to work fine when I first got my computer and just up and quit one day. It has been going on for awhile now and no one can seem to fix it. The speakers are fine because I play music and watch movies all the time, it's only when i have WoW open that it does this. Here are the responses I've received from several different sources:
Outdated drives (Updated all drivers and it didn't help.)
Bad soundcard
Something in the tower being too old and not being able to handle so much (this came from Geek Squad. Forgive my vagueness, but I stopped listening when he told me they couldn't fix it.)
And lastly: eMachines sucks. (My personal favorite. Helpful, no?)
I've been on several forums that I found via Google...this site never came up...and no one has been able to help, most of the time I don't get any responses.
My warranty expired already so I have a feeling that it's going to be something expensive that I can't afford right now. My luck kinda sucks as of late.
Please say you can help. :)
  • 0

Advertisements


#2
Araxathan

Araxathan

    New Member

  • Member
  • Pip
  • 5 posts
hm, I had a problem like this myself but it was more of the odd crackling whilst playing WoW especially in the newer content (Tbc & WotLK) what operating system are you running on?
  • 0

#3
Samilyn

Samilyn

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Crackling sound better explains it at certain times. I use Windows Vista, if that's what you meant (sorry, I'm not exactly the most knowledgeable person when it comes to computers).
I remembered that the problem started roughly around the time that I installed the software for my printer. I immediately uninstalled it, since I don't print anything very often, and hoped that would fix everything. Alas, nothing changed. I refer back to my shortage of luck.
Were you able to fix your problem?
  • 0

#4
Araxathan

Araxathan

    New Member

  • Member
  • Pip
  • 5 posts
I don't normally get the problem anymore I only used to get it In hellfire and blades edge
it seems like it was mainly the desolate places and I sometimes still get it how bad exactly is the crackling?
If i'm honest with I mainly turned off my sound whilst I was in this areas but you'd be better off going on wow-europe forums or the US version where every your from go to technical support and it has a support guide to sound problems with windows vista ifyour sound issues continue to persist the I'd suggest you contact customer support via email or whatever suits youths most sorry o couldn't be a major help to your issues but if I'm honest I never really did anything with mine
  • 0

#5
JennyS

JennyS

    Member

  • Member
  • PipPip
  • 22 posts
I had this happen on my old computer, but I don't remember how I fixed it. :)

Have you tried turning on the background sound option in-game?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP