Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

PC very slow since Trojan fix


  • Please log in to reply

#1
davidc51

davidc51

    Member

  • Member
  • PipPip
  • 43 posts
Many thanks for the help you gave me in getting rid of my previous trojan problems.
However, since that fix my PC has been running slower than ever. I now have more security running and I have now updated windows as recommended by you. I only have 512MB ram but the machine is really only used for browsing and Email with occasional use of word, xl photoshop etc etc.
PC is a Dell Optimax 270 Pentium4 3GHz running XP pro SP3.
When I open Outlook Express the splash screen appears after about 30 seconds and then it takes about another 30 seconds before the program opens.
Firefox takes about 90 seconds to open. Opening new tabs (once the program is running) only takes 8 - 10 seconds.
Any right click on an icon or the task bar takes about 10 seconds to open the menu and around another 70 seconds to open whatever I click on.
I have de-fragged the disks and cleaned the temp files using your recommendations.
Any suggestions please?

Thanks in advance
DavidC
  • 0

Advertisements


#2
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Download Autoruns from the link in my signature below:
1: Extract the Autoruns Zip file contents to a folder.
2: Double-click the "Autoruns.exe".
3: Click on the "Everything" tab
4: Remove any entries that mention "File Not Found" by right-clicking the entry and select Delete.
5: Go to File then to Export As or Save in some versions.
6: Save AutoRuns.txt file to known location like your Desktop.
7: Attach to your next reply.

  • 0

#3
davidc51

davidc51

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
See attached file

NOTE: The first time I ran the program I accidently saved the output in .arm format and it's too big to attach on the reply- so this is the second pass. Can I convert the arn file into a txt file to attach it?

DavidC

Attached Files


  • 0

#4
davidc51

davidc51

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Sorry - I loaded the first scan into autoruns and saved is as txt - hopefully this is scan No 1.

Apologies
DavidC

Attached Files


  • 0

#5
davidc51

davidc51

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
** EDIT ** Ignore this reply please.
Had CD drive pack up after running Autoruns. Device manager showed no hardware present. Swapped hardware for another drive and uninstalled anydvd but wouldn't read or write but device manager did recognise it. Installed first drive again and all working OK. Just wondered if anything in Autoruns could have affected it or if it was just coincidence.
No problem though 'cos it seems to be working OK again now.
DavidC

Edited by davidc51, 16 December 2009 - 12:24 PM.

  • 0

#6
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
First of all I apologize for the long response time but i have been sick for awhile and just now getting back up to speed. Let's see if we can fix this now.

Open Autoruns, click on "Logon" tab, and UN-check:

"HFFSRV"
"HotKeysCmds"
"IgfxTray"
"NBKeyScan""Adobe Gamma Loader.lnk"
"WinampAgent"
"Adobe Gamma Loader.lnk"
"AnyDVD"


The next file needs to be manually disabled and is only needed if you use multi language on your keyboard. If you do then skip the step.


To turn off just ctfmon.exe go to:

Control Panel then to Regional and Language Options

Click on the Languages Tab then click the Details button

Click on the Advanced tab

Check the box that says Turn off advanced text services option

Click A and then OK



When done restart computer and then:



Download TFC by OldTimer to your desktop
  • Please double-click TFC.exe to run it. (Note: If you are running on Vista, right-click on the file and choose Run As Administrator).
  • It will close all programs when run, so make sure you have saved all your work before you begin.
  • Click the Start button to begin the process. Depending on how often you clean temp files, execution time should be anywhere from a few seconds to a minute or two. Let it run uninterrupted to completion.
  • Once it's finished it should reboot your machine. If it does not, please manually reboot the machine yourself to ensure a complete clean.


Download Auslogics Defrag from the link in my signature below. Auslogics Defrag in my opinion is better because:
It does a more comprehensive job at Defragging
It will actually show you what it is doing
At the end of working it will show you how much speed you picked up
You can view a online log of the files that Auslogics defragged


Let me know how system is running when all completed. :) :)
  • 0

#7
davidc51

davidc51

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Thanks for the reply.
Done all that now but it doesn't seem to have improved things - Firefox just took 97 seconds to open and IE about 65 seconds- although Outlook Express did seem to open a bit faster. A right-click on the taskbar took 14 seconds before the programs appeared (initially just a white, empty, box)although it is quite fast the second time I try it.
Firefox is OK once I am using it but slows down again after I have used another application. This seems to be the case with all applications - slow to open initially then OK but slow to switch back to if several other applications are running (if that makes sense!)
  • 0

#8
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
So the problem is the browsers and not the system from what you are saying in your last post?
Try this:
To disable add-ons in Internet Explorer 8
1. Open Internet Explorer by clicking the Start button Picture of the Start button, and then clicking Internet Explorer.
2. Click the Tools button, and then click Manage Add-ons.
3. Under Show, click All add-ons.
4. Click the add-on you want to disable, and then click Disable.
5. Repeat step 4 for every add-on to disable. When you are finished, click Close.
Now restart IE and retry IE as before. Let us know if it still happens or not. If not then try enabling one add on at a time and trying IE again till you find the problem.
Most times the cause will be a toolbar add on.


Also try this for Fire Fox

* Go to Start and then to Run
* Type in firefox -safe-mode
* A window will popup asking things that you want to disable or reset (eg: reset/disable bookmarks/toolbars, etc.)
* Click Disable all add-ons and press Restart for the changes to take effect.


Let me know if Firefox runs faster now.
  • 0

#9
davidc51

davidc51

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Hi
With add-ons disabled in IE it does start a little faster - about 10 seconds now to open.
Firefox has improved from mind-numbingly slow to just very slow. When I started it this morning the first time it took over 2 minutes to open. After disabling all add-ons it took only about 1 minute.
It's not just browsers though. I use this machine mainly for internet browsing so I notice it more on outlook express and the browsers. Photoshop takes around a minute to open and a click on the quick start toolbar takes 10 seconds or so for anything to appear.
Overall the machine has definitely improved going from disasterously slow to just very slow.
Is it possible that more memory would help significantly? (although it has only recently become slow - the machine was fine a month ago and the only software that I have loaded in that time is the MS updates and security stuff that you advised following my virus problems)
Regards
DavidC
  • 0

#10
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi guys...

Excuse my butting in, but my curiosity got the best of me...

Let's take a quick look at the transfer modes. Right click on My Computer and choose "Properties". Click the "Hardware" tab and then the "Device Manager" button. Expand (click +) IDE ATA/ATAPI controllers.

Right click on the Primary IDE channel, choose "Properties", then click the "Advanced Settings" tab. List the Current Transfer Mode for each device shown for this channel.

Right click on the Secondary IDE channel, choose "Properties", then click the "Advanced Settings" tab. List the Current Transfer Mode for each device shown for this channel.

wannabe1
  • 0

Advertisements


#11
davidc51

davidc51

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Hi
For primary IDE channel both device 0 and 1 are set to Ultra DMA mode 2
For secondary channel device 0 is Ultra DMA mode 4 and device 1 is not available

DavidC
  • 0

#12
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Thanks Wannabe1 you are always welcome to butting in :)

davidc51 try this while we wait on wannabe1
Lets see what you have in your startup

Please click on
Start and then to Run
Type in msconfig and press Enter
Now click on Startups
Then uncheck everything and restart.
If system boots correctly and is running smoothly and faster then we have a startup problem
Try going back into msconfig and check one item and reboot
Keep doing that till you have found the problem or all are finally checked.
Post back with the results
  • 0

#13
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
The transfer modes are correct.

There are times when the machine will set the transfer modes to PIO (Programmed Input/Output) which will make a machine excruciatingly slow. Just thought it would be a good idea to check them.

Carry on......... :)
  • 0

#14
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Thanks Wannabe1 I'm running a little slow lately so your advice was appreciated for sure. :) :)
davidc51 after trying the startup steps then try the below.. Hopefully either startups or services is causing the slowdown in the system itself.

Lets see what you have in your startup services area

Please click on
Start and then to Run
Type in msconfig and press Enter
Now click on Services
Click on the Hide All Microsoft Services
Then uncheck everything and restart.
If system boots correctly and is running smoothly and faster then we have a startup problem
Try going back into msconfig and check one item and reboot
Keep doing that till you have found the problem or all are finally checked.
Post back with the results
  • 0

#15
davidc51

davidc51

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
OK....disabling everything in startups didn't seem to make any difference.
Disabling everything in services did seem to speed things up a bit (Photoshop has been taking 70 - 90 seconds to open but it now took 50 - 55 seconds. Still not fast but slightly better) and quick start menu and right clicks seemed a little faster.
I enabled services 6 at a time at first and found that 'Nero back it up scheduler', 'Acronis try and decide', 'Tune up driver defrag' and 'tune up program statistics' seemed to slow things up a bit. It did seem fairly random as any combinations of those seemed to make the system run a bit slower - if they were all enabled or any one of them!
With any combination of these 4 items enabled the quick start menu seemed slightly slower and opening applications took 50 -70 seconds ( with these 4 removed applications took about 45 - 55 seconds)
I've spent several hours doing this but don't know if I have actually proved anything!
By the way, can these 4 items stay disabled or do I need them for anything?
DavidC
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP