Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

How can I disable InPrivate Browsing on XP Home?


  • Please log in to reply

#1
jen147

jen147

    Member

  • Member
  • PipPipPip
  • 223 posts
Hello... I'm the Mom of a teenager, and find this feature totally stupid from that stand point. I've been looking online and it seems it's hard to disable when you have Windows XP home edition. I have IE 8. Anyone have any solutions for my particular system?

Would really appreciate your help!
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
This is a feature of Internet Explorer 8, not XP, therefore it's irrelevant whether you have Home or Pro.

From the help file for IE8:

If you've already turned on InPrivate Filtering, follow these steps:

Open Internet Explorer.

Click the Safety button, and then click InPrivate Filtering Settings.

Do one of the following:

To automatically block websites, click Automatically block.

To manually block websites, click Choose content to block or allow.

To turn off InPrivate Filtering, click Off.

Click OK.


  • 0

#3
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
that would just turn it off...at which point the kids could just turn it back on

the reason it's difficult in XP home is because the suggested method of disabling in private browsing is to use group policy, which doesn't exist in xp home

one good option would be to use Windows Live Family Safety

With Family Safety, you decide how your kids experience the Internet. Limit searches, monitor and block or allow websites, and decide who your kids can communicate with in Windows Live Spaces, Messenger, or Hotmail.*


or you can disable private browsing in the registry

How to Disable InPrivate Through the Registry

1. Open Regedit. press start, then run, then type "regedit" (without the quotes)

2. The necessary setting is: HKey_Local_Machine\Software\Policies\Microsoft\Internet Explorer\Privacy\EnableInPrivateBrowsing

if that key doesn't exist (everything after internet explorer doesn't exist on my computer)...you may have to create them...do do this, navigate to the last available section of the key...mine stops at HKey_Local_Machine\Software\Policies\Microsoft\ so that's where the following instructions begin

right click on Microsoft in the left pane and choose new, then key. Type "Internet Explorer" (no quotes) as the name of the key. Then right click on the new key you created and choose new, then key and type "Privacy" (no quotes) as the name of the key. highlight the new privacy key, and then right click in the RIGHT pane, choose new, then dword value. Type "EnableInPrivateBrowsing" (no quotes) as the name of the item. The value will default to 0 (which is what you want). now restart your computer and you should no longer be able to enable in private browsing
  • 0

#4
jen147

jen147

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 223 posts
dsenette, you're my hero!!! :)

It went very smoothly. After the restart, I opened IE then selected another tab and there was no option to open a tab for InPrivate Browsing. I'm thrilled actually.

The only mention of it is the following sentence which is a link as well:

Learn more about tabs and tab shortcuts, Accelerators, and InPrivate Browsing

Will this be ok do you think. I think it's just an info type article. If I ever wanted to reinstall it (which I can't imagine that ever happening) would I just change that data value of "0" to a "1" or something?

Thanks so much, you Rock!
  • 0

#5
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP

Will this be ok do you think. I think it's just an info type article.

i would imagine that would be fine...you could click it and see what it does

If I ever wanted to reinstall it (which I can't imagine that ever happening) would I just change that data value of "0" to a "1" or something?

yeah...either change it to 1 or delete the whole key and in private should come back
  • 0

#6
nortonbiz

nortonbiz

    New Member

  • Member
  • Pip
  • 1 posts
I tried this and at first couldn't get it to work. It was my mistake however. I left out typing in Internet Explorer...

This is great! Thank you so much for your help!

Would this work with Vista and Win7 too?

Thanks again!!!

Edited by nortonbiz, 13 April 2010 - 12:00 PM.

  • 0

#7
Ferrari

Ferrari

    PC SURGEON

  • Member
  • PipPipPipPip
  • 1,939 posts
Nice Info... good job dsenette :)
  • 0

#8
Happy Camper!

Happy Camper!

    New Member

  • Member
  • Pip
  • 1 posts
This was a Great Fix! I have another laptop where i was able to do the group policy but using my xp Home had me stumped! Thank you so much... This info is very much appreciated... :D
  • 0

#9
jen147

jen147

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 223 posts
Hi, I came back to this question that I posted a long time ago because now I've got a new computer with Win 7, so how do I totally disabled inprivate browsing for all users? I looked online and found one solution here: http://www.sevenforu...le-disable.html

I used their option 1 but it is only working for my administrator account, it didn't change a thing for my other user.

Any solutions?
  • 0

#10
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
again, inprivate browsing has nothing to do with the operating system, it's all about the browser.

did you try doing what i suggested 2 years ago? because those steps should still apply
  • 0

#11
jen147

jen147

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 223 posts
I guess the reason I mention the operating system is because on the net you read to disable the inprivate browsing is through that group policy again... and unless I'm not looking hard enough i can't access it in Windows 7 Home Premium. But I should have looked closer at your fix for the XP. I just assumed that it was like the group policy fixes I've seen on the net, now I see that it was not. It was my mistake.

The admin at sevenforums.com fixed his reg file download so that it affects all users on a PC (which was the problem I was running into... his fix was working for just one user)... can you check it out and see if basically it's the same as your fix to go in manually?

After I posted to him he fixed it and then I downloaded it again and it worked. So I've got the inprivate browsing disabled for all users now... but I wondered if you'd take a look at it and make sure it was a safe alternative.

Thanks!
  • 0

#12
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
the fix on the sevenforums page, is basically EXACTLY the same thing as the registry steps i mentioned way back when, just in a file that does it for you instead of you having to do it manually.

in fact, the method i posted before (the manual method) is the one that makes the setting apply system wide, his original fix (while valid) was the one that just effected the user that ran the file.
  • 0

#13
jen147

jen147

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 223 posts
Thanks dsenette!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP