Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Total USB Faliure

  • Please log in to reply




  • Member
  • PipPip
  • 25 posts
Hi, I have a dell Dimension 9100 that decided it would rather not have working USB ports last night. To be up front, I was doing some data management with my Sony PSP, when the power shut off on the PSP. Thinking it was just the PSP, i just plugged it into the wall. Then I go back to use the PC and the mouse doesn't work, just the keyboard. After a restart, I go into the system (right clicking on my computer) and manage the hardware by trying to troubleshoot the issue. The system has seven USB ports. I already knew one of them wasn't working, but I had six more so I never bothered to fix the issue.

Like an idiot, I disabled one of the TWO that worked by hand, and when I disconnected the keyboard to swap the last working port with the mouse, I heard the USB disconnect sound, but didn't hear the connect sound when I plugged the mouse into where the keyboard used to be. I don't have any excuse save for it being 4am and not being in a lucid state of mind.

Anyhow, now I essentially am the proud owner a 50lb paper weight, as I cannot enter safe mode. Exacerbating the issue is the fact that Dell (thanks guys!) never shipped me a windows XP cd. I accquired one through a co worker, who claimed to not need it when he bought his new system (it came loaded with vista and they threw xp in). About a month ago, I tried using the CD to repair windows, and it said it wouldn't work, as the version that was installed on my system was newer than the one on the disk. I am guessing it was service pack 2, and I have SP3 installed.

So now, I have no way to get access to my BIOS. From the vague things that I've read, sounds like I am going to either need a PS2 adapter or an AT style keyboard....

If you think it would help, I can attach a picture of the back of my PC to show you what ports I have.

Luckily, I have a 500GB external Drive, and an expansion drive that I've already removed with all data backed up from my C drive. I will try to get in contact with Dell for a CD key.

I usually ask you all for software advice, but this one is really above my head. I would like to avoid taking my PC to a repair shop; I'm not fond of people having access to my data. Hopefully I can get around this. Please help.

Thanks in advance for reading this.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP