Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Super weird USB problem.

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Before even writing here my system specs, or what is the problem I have right now, i will just list a few things that have happened to me recently since i got this new PC, hope these can get your attention since I am actually not pissed because of the problems im having, im actually very intriged about it:

- When I turned off my usb external hard drive (Iomega, 500gb), the wireless usb card (Belkin F5D8055 v2) stopped working.
- When Windows is booting up, if i have my wireless usb connected *sometimes* windows won't load.
- Before this Belkin usb card i had a Linksys and im having the same problems as before.
- Keyboard and mouse sometimes restarts (they stop working and then Windows recognises them and they start working again) just as if I unplugged them and plugged them back.

I can assure all my USB devices were installed correctly, with the drivers for each. Except for the mouse and my keyboard, and my external drive. Those I dont have any specific driver other than the one Windows use for them

With both wireless USB cards i had problems with windows recognising them. I've had the keyboard/mice flashing problem without having any USB wireless card connected.

This is a brand new PC and the system specs are as follows:
Windows Vista 64 bit
NVIDIA GeForce GTX295 1792MB
8GB (4x2GB) DDR3 1333
1TB SATA-II 3.0Gb/s 7200RPM HDD
Intel Core i7 870(2.93GHz) 8MB L3 Cache
ASUS P7P55D LE motherboard

This is a CyberpowerPC rig and I've already contacted the support via email with no luck. If all this problem persists, and are actually a hardware related issue that i could solve with the warranty Ill do so after holidays. Im just pretty curious of what could be going on since this has never happened to me and ive worked with a lot of PCs in the past!

If any of you have any idea of what could be going on and how could I fix this it would be very appreciated

Another thing important to remark is I have been able to get the USB wireless working, after some trouble with drivers/recognising. Then I just turned off my external HD since i was not using it. And then the wireless died, and never came back.

Ive installed the motherboard drivers but im staying away from the Windows Vista updates since the last time i tried to install the Sp3 it kept freezing on the last installation step and i had to format the PC. Posting this from my laptop.

Thank you in advance

Even after reinstalling the USb wireless card drivers and repeating the process, it has problems connecting to wireless networks, and frequently the connection has gigantic lag spikes, along with random discnonects. It is pretty unstable.

When i connect my external HD, the belkin usb wireless won't work at all: it is recognised by the system, but it wont find any wireless connection.

Edited by elugoruiz, 24 December 2009 - 12:10 PM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP