Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

How do I get a printer to work with 2 pc's?


  • Please log in to reply

#1
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Member
  • PipPip
  • 39 posts
Hi guys,

I have 2 computer's mine and my Dad's. We have 1 printer that is hooked up to the computer that is not using the wireless adapter. My question is: Is there someway to be able to print wirelessly, well I mean I know there is, but how do I go about doing it?

Thanks in advance :)
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Without adding some sort of network connectivity to the PC with the printer connected, you can't really do it.
Likewise you can't drive the car to the petrol station without putting some petrol in it first.
  • 0

#3
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
Well, I have network connectivity, I can go on the internet on both pc's.

I have a Linksys Wireless Router hooked up to 1 computer, and a Linksys Compact Wireless-G USB Adapter on the other(the one that is in a different part of the house)

With this setup, is it possible to be able make the pc that has the wireless adapter print to computer #1's printer?

Thanks
  • 0

#4
Spyderturbo007

Spyderturbo007

    Member

  • Member
  • PipPipPip
  • 760 posts
Yes you can. I'll assume they are both Vista machines.

On the machine attached to the printer:

Go to Start -> Control Panel -> Network and Sharing Center. Scroll down until you see Printer Sharing and verify it is set to Turn on Printer Sharing. Once you've done that, go to Control Panel -> Hardware and Sound -> Printers, right click on the printer you want to share and chose Sharing. Then click on Share this Printer and provide a share name if you don't like they default one.

Now, go to the wireless machine and do the following:

Go to Start -> Control Panel -> Printers and click on the Add Printer button. This will bring up the wizard that will walk you through the steps to connect to the remote printer. You'll want to choose Add network printer and then browse for a printer. Click the printer you want, confirm the driver installation and you're all done.
  • 0

#5
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
Hey Spyderturbo007,

Thanks for replying! :)

Ok, I did what you said, but on the wireless computer, it doesn't find a printer on the add printer screen. :)

So I clicked: The Printer I want isn't listed so then I clicked Browse for a Printer a hit next.

I think the problem is that I don't see the other computer, I only see this one. :)
  • 0

#6
Spyderturbo007

Spyderturbo007

    Member

  • Member
  • PipPipPip
  • 760 posts
I'm getting ready to head home from work, so I'll have to be brief here. What you'll want to try is manually pointing the wireless PC to the wired PC using the computer name and printer name we chose above. You can get these from the computer where the printer is attached. Take this information to the wireless client and start through the add printer wizard again but don't browse for a printer this time. Choose the option for selecting a printer by name.

\\ComputerName\PrinterName

Substitute the name of your computer with the printer for ComputerName and substitute the name of the printer for PrinterName. That will manually point the wireless client to the printer.
  • 0

#7
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
I tried that, it doesn't work either. :)

Edited by jimiclaptoncarl, 28 December 2009 - 03:08 PM.

  • 0

#8
Spyderturbo007

Spyderturbo007

    Member

  • Member
  • PipPipPip
  • 760 posts
Can you check to make sure that both computers are listed as being in the Private Network Zone and members of the same workgroup?

To check the network zone, go to Start -> Right click Network -> Properties.

To find workgroup information, go to Start -> Right click Computer -> Properties.
  • 0

#9
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
Wait, so what should I actually be seeing?
  • 0

#10
Spyderturbo007

Spyderturbo007

    Member

  • Member
  • PipPipPip
  • 760 posts
You'll want them both to be listed in the Private Network zone when you are connected at home. As for the workgroup, just make sure they both have the same name. Vista defaults to WORKGROUP, so if you haven't changed anything, they should be the same.
  • 0

Advertisements


#11
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
Okay, the #1 pc is under Network 2(Private Network) and it has the name workgroup.

The wireless pc is under GSHOME(Private Network) and it also has the name workgroup.

So they need to be in the same network?
  • 0

#12
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
Here's what I get when I try to add printer by name:

Windows cannot connect to the printer. The server print spooler service is not running.
Please restart the spooler on the server or restart the server machine.

:)
  • 0

#13
Spyderturbo007

Spyderturbo007

    Member

  • Member
  • PipPipPip
  • 760 posts
In order to try this, you need to be logged in as an administrator.

Go to Start -> Control Panel -> System Maintenance. Double click on Services and then right click on Print Spooler and choose Properties. Under the General tab, you want the startup type to be set to Automatic. Also, if the service isn't running, which it sounds like it isn't, click Start then click OK.

After you get that running, try to reinstall the printer.

Edited by Spyderturbo007, 29 December 2009 - 01:14 PM.

  • 0

#14
jimiclaptoncarl

jimiclaptoncarl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
I've done that... :)

I think this is the problem: pc#2 doesn't recognize pc#1, but pc#1 does recognize pc#2.

pc#1 is the pc connected to the router, pc#2 uses the wireless usb adapter.

Edited by jimiclaptoncarl, 29 December 2009 - 01:23 PM.

  • 0

#15
Spyderturbo007

Spyderturbo007

    Member

  • Member
  • PipPipPip
  • 760 posts
What happens when you try to start the service? Does it start correctly and you still get the error message?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP