Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Empires:Dawn of the Modern World crash on start up


  • Please log in to reply

#1
c2cksro

c2cksro

    New Member

  • Member
  • Pip
  • 7 posts
my empires dawn of the modern world will not start up, it starts to load and then CTD, and i've had the game for like 5years now, and everything is still the same...same CPU same everything and it used to work..then it did the CTD stuff...and then worked again...and now it just always crashes to CTD..i have the oringal CD and CD key..so yah..dunno what the deal is
  • 0

Advertisements


#2
rev_olie

rev_olie

    Member

  • Member
  • PipPipPip
  • 532 posts
Hi again,

Thanks for creating a new topic. It helps to keep support personal and the board tidy :)

I am expecting this to be a driver issue...hopefully.

Have you changes your operating system recently or since the game last worked?
And had you made any other changes since the game last worked?

Please can you download and install Everest from HERE
Once its installed (leave all of the options just keep pressing next) double click on the shortcut.
Then once its running:
1: In left pane expand Computer folder.
2: Click once on Summary
3: In upper menu, go Report
4: And then to Quick Report-Summary
5: Save it in text file, and attach it to your next post

Don't include anything under the line "DEBUG- PCI"

2

Please download VEW and save it to your Desktop:

Setting up the program
Double-click VEW.exe then under Select log to query, select:
  • Application
  • System
Under Select type to list, select:
  • Critical (Vista only)
  • Error
  • Click the radio button for Number of events
  • Type 20 in the 1 to 20 box
  • Then click the Run button.
  • Notepad will open with the output log.
  • Save it to your desktop
Can you please Attach both of these logs as they can be fairly long. Any problems just ask :)

Attached Thumbnails

  • Everest.jpg

Edited by rev_olie, 30 December 2009 - 06:17 PM.

  • 0

#3
c2cksro

c2cksro

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
hmm..I don't think its a driver problem...it only does this with this game..all the others no problem at all..and nope same OS
  • 0

#4
c2cksro

c2cksro

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
k here yah go

Attached Files


  • 0

#5
rev_olie

rev_olie

    Member

  • Member
  • PipPipPip
  • 532 posts
Ok there are a couple of things in your log we could do to sort.

1
Application Event ID 8

In Control Panel, double-click Add/Remove Programs.
Click Add/Remove Windows Components.
Click to clear the Update Root Certificates check box, and then continue with the Windows Components Wizard.

2
Do you use MSN or some other instant messaging service?

3
You have some errors regarding Mcafee. Do you still use it? If so I would advise you uninstall and reinstall the program as it appears to be corrupt in some way.

4
Do you have the latest patches for the game installed?

Patch 1.1
Patch 1.2
Patch 1.3

5
Can you give me some more details on your system?
Please can you give me the Make and Model of your PC.

Edited by rev_olie, 31 December 2009 - 06:07 AM.

  • 0

#6
c2cksro

c2cksro

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Hey i got it to work! woohoo, I uninstalled Mcafee, and the update root certificates, and installed all the patches, thank you! :)
  • 0

#7
rev_olie

rev_olie

    Member

  • Member
  • PipPipPip
  • 532 posts
No problem at all :)

Seems Mcafee had a part in the problems.
However now you have uninstalled Mcafee make sure you have some form of protection. Take a look Here for some suggestions.

If the problem occurs again then pop back and we can take another look.
:)
  • 0

#8
c2cksro

c2cksro

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
so, i just tried a test run of the game right, as franks and i have 200 food, tho its all reded out and i can't create a worker, says 'not enough resources' though i got 200 food..lol
  • 0

#9
c2cksro

c2cksro

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
nevermind, a reboot helped with that :) thank you again
  • 0

#10
rev_olie

rev_olie

    Member

  • Member
  • PipPipPip
  • 532 posts
Haha no problem :)
  • 0

#11
skull78

skull78

    New Member

  • Member
  • Pip
  • 2 posts
Thanks heaps.
It turned out just to be a patch issue with me.
1.0 wouldnt run, but installed the patches and it works fine :)

Thank you again :)
  • 0

#12
naj92

naj92

    New Member

  • Member
  • Pip
  • 1 posts
hello ! guys i want to play dawn of modern world but the full game does't work on my pc demo is playable i don't know why it doesnt work i have upgraded direct x to the latest my pc applications are as follows
INTEL®ATOM ™
CPU N270 1.6O GHZ
1 GB RAM
SYSTEM XP SP3
32 BIT
GRAPHIC CARD IS INTEL CHIPSET FAMILY BUIID IN
  • 0

#13
bradleybrand

bradleybrand

    New Member

  • Member
  • Pip
  • 4 posts

I am experiencing the same issue. I have a Windows 7 computer with an NVIDIA GeForce GTX 660 series graphics card. The game has worked on my computer in the past but recently I reinstalled Windows and when I reinstalled Empires: DOTMW, the game did not work. I have tried what has been recommended, but no luck. What should I do?


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP