Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

reboot and select proper boot device


  • Please log in to reply

#1
bfaraj

bfaraj

    New Member

  • Member
  • Pip
  • 2 posts
Hello. :)

Recently, my computer had its power accidentally cut out (plugged the electricity out) without being properly shut down prior to it. Now, I get an error before Windows even begins booting:

reboot and select proper boot device or insert boot media

Now I have the opportunity, before this error appears, to press DEL to enter BIOS. I did so and went into the Boot tab. There, I had 3 choices:

HDD - something something
Removable Device
CD-Rom

There are 2 HDDs in my computer by the way.

I tried putting HDD before Removeable Device and Removable Device before HDD but neither worked.

What DID work though is tapping F8 as the PC is booting. That opened a single window asking me which device to boot from. There, I also had 3 choices:
HDD - something something (as in numbers)
SATA - something something
CD-Rom

Choosing SATA works. I assume "Removable Device" in BIOS' boot tab is SATA but that didn't work. IT only works if I tap F8 continuously and choose SATA in the window.

SO basically now, whenever I want to be able to use my computer (windows 7) I need to tap F8 as the PC is booting and choose SATA.

So I guess the solution would be to somehow get SATA to appear in the choice of boot priorities in my BIOS.

Help would be appreciated!!

Thank you!!
  • 0

Advertisements


#2
Fllash

Fllash

    Member

  • Member
  • PipPip
  • 24 posts
(the power outage may have, if windows seems intact, reset your CMOS)
What i have noticed is that selecting HDD as the first or primary boot option is only half the deal.
You should see (under the boot tab) an menu that you can enter allowing you to select which physical HDD to boot from - just enter into it and select the drive that is not currently in the first position, and switch them around.

If there is no such menu (though there should be), you can use a program called 'EasyBCD' to rewrite the bootsector to whatever hard drive is in first position, and that should fix it up. But the options you are looking for should exist in the bios somewhere under BOOT.

Thanks,
Josh.
  • 0

#3
bfaraj

bfaraj

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
That worked.

Thank you kindly, I'm not sure how I didn't notice this menu!

Thanks a lot and happy new year.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP