Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows XP Service PAck 3 will not install


  • Please log in to reply

#1
evano711

evano711

    Member

  • Member
  • PipPip
  • 19 posts
I recently(thanks to the help of the brilliant minds at this website) eradicated a virus which completely messed up my operating system to where it would log me off as soon as I logged in. I reinstalled Windows XP Professional Media Center Edition with my re installation disk to fix the problem. Now I am stuck in Service Pack 2. I cannot install Service Pack 3 for some reason that I am not sure off. When i reinstalled my OS i got these two errors. I do not know if they could be part of the problem

The procedure entry point GetRequestedRuntimeVersion could not be located in the dynamic link library mscorce.dll

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorwks.dll could not be loaded.

I have no idea how to fix this any help would be great.
  • 0

Advertisements


#2
Robin Hood

Robin Hood

    Banned

  • Banned
  • PipPipPip
  • 268 posts
Howdy evano711. :)

Both of these errors appear to be caused by a corrupt version of the Framework.

Please follow my below instructions carefully to ensure the corrupt version is fully removed and replaced with a clean install. If at any point you don't understand or have a question, don't hesitate to ask. :)


Firstly, let's uninstall the corrupt version.

To manually remove and reinstall the .NET Framework, follow these steps:

1. Click Start
2. Click Control Panel
3. Click Add/Remove Programs
4. Uninstall all the versions of the .NET Framework present
5. Reboot your computer when prompted



Next:

1. Download the Windows Installer Cleanup Utility to your desktop:

http://download.micr...1bd/msicuu2.exe

2. Double click on the installer
3. Follow the prompts to install
4. Go to Start > All Programs > Windows Install Cleanup
5. Remove all instances of the .NET Framework
6. Reboot your computer



Finally:

1. Go to the following link to download the latest .NET Framework

http://www.microsoft...;displaylang=en

2. If you have any issues installing that version, please go to this article and select the next compatible version:

http://support.microsoft.com/kb/923100



Let us know how it goes. :)
  • 0

#3
evano711

evano711

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
While awaiting an answer last night. I decided that the Framework was the issue due to the error i got when installing. I deleted all of the frameworks off my computer and it loaded up right away! Do I need to reinstall those framewroks that i deleted. I think its was Framework 1.0 Service pack 2 Framework 2.0 Service Pack 2 and a Framework 3.5
  • 0

#4
Robin Hood

Robin Hood

    Banned

  • Banned
  • PipPipPip
  • 268 posts
Good to hear you were able to remove the corrupt versions. :)

Install the .NET Framework 3.5 and see how it goes. If any of your programs request a different version then imstall that requested version. Otherwise you should be fine with 3.5. :)

Did the 2 errors disappear?
  • 0

#5
mybuddyeric

mybuddyeric

    Member

  • Member
  • PipPip
  • 26 posts
While we're talking about .NET, is it a good idea to leave previous versions installed on a machine? Like 1.0, 2.0, and 3.5? Are they dependent on each other or can just the most recent version be installed with no problems?
  • 0

#6
Robin Hood

Robin Hood

    Banned

  • Banned
  • PipPipPip
  • 268 posts

While we're talking about .NET, is it a good idea to leave previous versions installed on a machine? Like 1.0, 2.0, and 3.5? Are they dependent on each other or can just the most recent version be installed with no problems?


It depends really. Some programs will only run on previous versions and so therefore the previous versions will be required. However, most of the time this is not the case and you would be perfectly fine to uninstall older versions and just use the latest.
  • 0

#7
mybuddyeric

mybuddyeric

    Member

  • Member
  • PipPip
  • 26 posts
Thanks Robin Hood! =)
  • 0

#8
Robin Hood

Robin Hood

    Banned

  • Banned
  • PipPipPip
  • 268 posts
Not a problem. :)
  • 0

#9
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts

While we're talking about .NET, is it a good idea to leave previous versions installed on a machine? Like 1.0, 2.0, and 3.5? Are they dependent on each other or can just the most recent version be installed with no problems?

yes... you should leave all of them on...
  • 0

#10
Robin Hood

Robin Hood

    Banned

  • Banned
  • PipPipPip
  • 268 posts

While we're talking about .NET, is it a good idea to leave previous versions installed on a machine? Like 1.0, 2.0, and 3.5? Are they dependent on each other or can just the most recent version be installed with no problems?

yes... you should leave all of them on...


Yeah it is actually a very good idea.
  • 0

Advertisements


#11
evano711

evano711

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
Which frameworks should i load? links? I am having problems with some programs well mainly 1 that ever since i had problems and reinstalled OS. Would the frameworks be to blame? I only have 2.0 installed now and i get an error when i try to run the program that pops up saying sorry for the inconvenience but it has t oclose
  • 0

#12
Robin Hood

Robin Hood

    Banned

  • Banned
  • PipPipPip
  • 268 posts

Which frameworks should i load? links? I am having problems with some programs well mainly 1 that ever since i had problems and reinstalled OS. Would the frameworks be to blame? I only have 2.0 installed now and i get an error when i try to run the program that pops up saying sorry for the inconvenience but it has t oclose


Hey evano711. :)

Here is the download link to 3.5:

http://www.microsoft...;displaylang=en

At the bottom of it you can find links to download the others. Make sure when you install them that it is done in a sequential order (ie. 1.1 before 3.5).

Which program is giving you this error?
  • 0

#13
evano711

evano711

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
i have most of them installed. when i try to install 3.0 and 3.5 it cannot connect to the server to download whne the installer pops up. how do i ffixx this
  • 0

#14
Robin Hood

Robin Hood

    Banned

  • Banned
  • PipPipPip
  • 268 posts

i have most of them installed. when i try to install 3.0 and 3.5 it cannot connect to the server to download whne the installer pops up. how do i ffixx this


Do you mean you have clicked on the download link and it fails to start?

Or have you started downloading?
  • 0

#15
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
the easiest way is to go to windows update...get everything it says you need both critical and important...
update will also get the patches/updates for any net framework...
the reason that program won't work is you don't have the version of net framework he used when he wrote the program

Edited by happyrock, 22 January 2010 - 07:49 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP