Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Printer Problem: Spooler Service Won't Start

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 5 posts
For some reason my Windows Spooler Service won't start. It had to have appened within the last week and a half but I don't know exactly when.

I tried going into Services and checking it, it is still setup as an "Automatic" service however it was not "Started". I tried to start it and I got this error message...

Could not start the Printer Spooler service on Local Computer.

Error 193: 0xc1

My next step was to open the C:\WINDOWS\system32\ folder and try to start "spoolsv.exe" manually. That yielded this error message...

C:\WINDOWS\system32\spoolsv.exe is not a valid Win32 application.

So... I'm stumped. When the Spooler Service went down it deleted my printer from Control Panel's "Printers & Faxes". Of course, I can not use the "Add a Printer" feature until after I get the spooler service running again. I tried to unplug the printer from the USB port, restart the PC, power up the printer and plug the USB port back in. It was as if nothing even happened at all.

I tried doing a Google Search and that yielded absolutely nothing... or "nothing useful." So now I am left at the mercy of your help. Hit me with your best shot 'cause I'm swinging and missing.

Just for S+G's, I am posting my Hi Jack This log below since it seems that everyone needs to see that log before they can conjure up a solution. I'm just going to post it now to prevent from having to come back and post it later.

Thanks for whatever help you can give me.

---- Start Hi Jack This log ---

Logfile of HijackThis v1.99.0
Scan saved at 5:59:23 PM, on 5/18/2005
Platform: Windows XP SP2 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

Running processes:
C:\Program Files\Norton AntiVirus\navapsvc.exe
C:\Program Files\Norton Internet Security\NISUM.EXE
C:\Program Files\Norton Internet Security\SymProxySvc.exe
C:\Program Files\Norton Internet Security\NISSERV.EXE
C:\Program Files\Creative\SBAudigy2\Surround Mixer\CTSysVol.exe
C:\Program Files\Creative\SBAudigy2\DVDAudio\CTDVDDet.EXE
C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe
C:\Program Files\Norton Internet Security\IAMAPP.EXE
C:\Program Files\Microsoft Hardware\Keyboard\type32.exe
C:\Program Files\Dell AIO Printer A960\dlbfbmgr.exe
C:\Program Files\Dell AIO Printer A960\dlbfbmon.exe
C:\Program Files\Java\jre1.5.0_01\bin\jusched.exe
C:\Program Files\Common Files\InstallShield\UpdateService\issch.exe
C:\Program Files\BPK\bpk.exe
C:\Program Files\Creative\SB Wireless Music\Media Server\SBWMsvr.exe
C:\Program Files\Webroot\Spy Sweeper\SpySweeper.exe
C:\Program Files\Creative\MediaSource\RemoteControl\RcMan.exe
C:\Program Files\Creative\Shared Files\Media Sniffer\MtdAcq.EXE
C:\Program Files\Belkin\Nostromo\nost_LM.exe
C:\Program Files\Logitech\SetPoint\KEM.exe
C:\Program Files\Logitech\SetPoint\KHALMNPR.EXE
C:\Program Files\Mozilla Firefox\firefox.exe
C:\Program Files\HijackThis\HijackThis.exe

O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 7.0\ActiveX\AcroIEHelper.dll
O2 - BHO: PK IE Plugin - {1E1B2879-88FF-11D3-8D96-D7ACAC95951A} - C:\PROGRA~1\BPK\bpkwb.dll
O2 - BHO: DriveLetterAccess - {5CA3D70E-1895-11CF-8E15-001234567890} - C:\WINDOWS\system32\dla\tfswshx.dll
O2 - BHO: Google Toolbar Helper - {AA58ED58-01DD-4d91-8333-CF10577473F7} - c:\program files\google\googletoolbar2.dll
O2 - BHO: NAV Helper - {BDF3E430-B101-42AD-A544-FADC6B084872} - C:\Program Files\Norton AntiVirus\NavShExt.dll
O3 - Toolbar: Norton AntiVirus - {42CDD1BF-3FFB-4238-8AD1-7859DF00B1D6} - C:\Program Files\Norton AntiVirus\NavShExt.dll
O3 - Toolbar: &Google - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - c:\program files\google\googletoolbar2.dll
O4 - HKLM\..\Run: [CTSysVol] C:\Program Files\Creative\SBAudigy2\Surround Mixer\CTSysVol.exe
O4 - HKLM\..\Run: [CTDVDDet] C:\Program Files\Creative\SBAudigy2\DVDAudio\CTDVDDet.EXE
O4 - HKLM\..\Run: [CTHelper] CTHELPER.EXE
O4 - HKLM\..\Run: [UpdReg] C:\WINDOWS\UpdReg.EXE
O4 - HKLM\..\Run: [ATIPTA] C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe
O4 - HKLM\..\Run: [NAV Agent] C:\PROGRA~1\NORTON~1\navapw32.exe
O4 - HKLM\..\Run: [iamapp] C:\Program Files\Norton Internet Security\IAMAPP.EXE
O4 - HKLM\..\Run: [IntelliType] "C:\Program Files\Microsoft Hardware\Keyboard\type32.exe"
O4 - HKLM\..\Run: [Dell AIO Printer A960] "C:\Program Files\Dell AIO Printer A960\dlbfbmgr.exe"
O4 - HKLM\..\Run: [Symantec NetDriver Monitor] C:\PROGRA~1\SYMNET~1\SNDMon.exe /Consumer
O4 - HKLM\..\Run: [SunJavaUpdateSched] C:\Program Files\Java\jre1.5.0_01\bin\jusched.exe
O4 - HKLM\..\Run: [MaxtorOneTouch] C:\PROGRA~1\Maxtor\OneTouch\Utils\OneTouch.exe
O4 - HKLM\..\Run: [Synchronization Manager] %SystemRoot%\system32\mobsync.exe /logon
O4 - HKLM\..\Run: [dla] C:\WINDOWS\system32\dla\tfswctrl.exe
O4 - HKLM\..\Run: [ISUSPM Startup] C:\PROGRA~1\COMMON~1\INSTAL~1\UPDATE~1\ISUSPM.exe -startup
O4 - HKLM\..\Run: [ISUSScheduler] "C:\Program Files\Common Files\InstallShield\UpdateService\issch.exe" -start
O4 - HKLM\..\Run: [bpk] C:\Program Files\BPK\bpk.exe
O4 - HKCU\..\Run: [SB Wireless Music] C:\Program Files\Creative\SB Wireless Music\Media Server\SBWMsvr.exe startup
O4 - HKCU\..\Run: [SpySweeper] C:\Program Files\Webroot\Spy Sweeper\SpySweeper.exe /0
O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
O4 - HKCU\..\Run: [RemoteCenter] C:\Program Files\Creative\MediaSource\RemoteControl\RcMan.exe
O4 - HKCU\..\Run: [MtdAcq] C:\Program Files\Creative\Shared Files\Media Sniffer\MtdAcq.EXE /s
O4 - Startup: Loadout Manager.lnk = C:\Program Files\Belkin\Nostromo\nost_LM.exe
O4 - Startup: Logitech SetPoint.lnk = C:\Program Files\Logitech\SetPoint\KEM.exe
O4 - Global Startup: Adobe Reader Speed Launch.lnk = C:\Program Files\Adobe\Acrobat 7.0\Reader\reader_sl.exe
O4 - Global Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office\OSA9.EXE
O8 - Extra context menu item: &Google Search - res://c:\program files\google\GoogleToolbar2.dll/cmsearch.html
O8 - Extra context menu item: Backward Links - res://c:\program files\google\GoogleToolbar2.dll/cmbacklinks.html
O8 - Extra context menu item: Cached Snapshot of Page - res://c:\program files\google\GoogleToolbar2.dll/cmcache.html
O8 - Extra context menu item: Similar Pages - res://c:\program files\google\GoogleToolbar2.dll/cmsimilar.html
O8 - Extra context menu item: Translate into English - res://c:\program files\google\GoogleToolbar2.dll/cmtrans.html
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_01\bin\npjpi150_01.dll
O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_01\bin\npjpi150_01.dll
O10 - Broken Internet access because of LSP provider 'xfire_lsp_10226.dll' missing
O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://v5.windowsupd...b?1104781912937
O16 - DPF: {D1E7CBDA-E60E-4970-A01C-37301EF7BF98} (Measurement Service Client v.3.4) - http://ccon.futurema...lobal/msc34.cab
O16 - DPF: {E7D2588A-7FB5-47DC-8830-832605661009} (Live Collaboration) - http://livenj01.righ...l/java/RntX.cab
O23 - Service: Ati HotKey Poller - ATI Technologies Inc. - C:\WINDOWS\system32\Ati2evxx.exe
O23 - Service: ATI Smart - Unknown - C:\WINDOWS\system32\ati2sgag.exe
O23 - Service: Creative Service for CDROM Access - Creative Technology Ltd - C:\WINDOWS\system32\CTsvcCDA.exe
O23 - Service: LexBce Server - Lexmark International, Inc. - C:\WINDOWS\system32\LEXBCES.EXE
O23 - Service: Norton AntiVirus Auto Protect Service - Symantec Corporation - C:\Program Files\Norton AntiVirus\navapsvc.exe
O23 - Service: Norton Internet Security Service - Symantec Corporation - C:\Program Files\Norton Internet Security\NISSERV.EXE
O23 - Service: Norton Internet Security Accounts Manager - Symantec Corporation - C:\Program Files\Norton Internet Security\NISUM.EXE
O23 - Service: ScriptBlocking Service - Symantec Corporation - C:\PROGRA~1\COMMON~1\SYMANT~1\SCRIPT~1\SBServ.exe
O23 - Service: Symantec Network Drivers Service - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\SNDSrvc.exe
O23 - Service: Print Spooler - Unknown - C:\WINDOWS\system32\spoolsv.exe
O23 - Service: Norton Internet Security Proxy Service - Symantec Corporation - C:\Program Files\Norton Internet Security\SymProxySvc.exe

--- End Log ---
  • 0




    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts

I found this... http://support.micro...kb;en-us;324757 ... and tried all of it...


I've been working on this for hours... I'm going to take a break and maybe it will just fix itself while I am sleeping. :tazz:
  • 0




  • Member
  • PipPipPip
  • 179 posts
Hi Hucklebuck

Man that sounds nasty, gotta love it when these things work, gotta hate them when they don't.

What you can quickly try to do is pop in your Windows XP cd, open a run command, and type in sfc /scannow, this will check and replace any needed system files that have been corrupted.
  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
I tried to do this but the command console gives me this message...

You must be an administrator running a console session in order to use the Windows File Checker utility.

That's messing with my patience because my account is the only administrator account that is setup on the PC. My wife is the only other "account holder" but she has a (very) limited account (she infected me before so now I have to do everything I can to prevent it from happening again).

Any suggestion on how I can make windows realize that I am the administrator running the session? I tried to manually open sfc.exe from withing the %systemroot%\system32\ folder after the command window failed and that did not work either.


--Edited addition ---
I was just wondering if I tried to pull the spoolsv.exe out of the %systemroot%\Dllcache\ folder and paste it into the system32 folder if that would possible fix a corrupted spoolsv.exe file (basically overwrite the current spoolsv.exe). I don't even know if the spoolsv.exe file is corrupted, I'm just getting desperate because I am going to need to use my printer VERY SOON :tazz:

Edited by Hucklebuck, 19 May 2005 - 03:10 PM.

  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
Ok... next update.

I was able to run the Windows System File Checker program by restarting in Selective Startup mode and loading the bare minimum. This *seemed* to fix the problem. I turned Selective Startup back off and restarted. Still seemed good, checked Windows Task Manager and spoolsv.exe was running.

Here's where the trouble starts again. I downloaded the latest drivers from Dell for my printer (A960). When I ran the program to install the drivers Windows Explorer had an error and restarted itself but it didn't seem to effect the Driver Install Program. The program finished its process and shut itself down. I then went into the Start menu, click on "Printers & Faxes". Nothing was listed. So I hit "Add a Printer"... I then got the same error message that I was getting before I ran the System File Checker. Operation could not be perfromed. Printer Spool is not running.

I reran sfc.exe (which worked from my administrator account this time) and decided to just plug the printer in the PC. PC recognized it right away. I tried to then use Add a Printer instead of running the driver install program. I had "Add a Printer" use Windows Update to find the driver on the net but of course that didn't work, that would mean Microsoft was actually good at something. Anyway, I remembered that the driver install program extracted some files before it would actually run so I found the folder that it extracted to C:\Dell\ I had the "Add a printer" look in that folder for driver and it found them. Everything seemed to be working, I was almost dancing on my chair. Then, when it was almost done, ERROR... Of course. It said something like Can not find correct print monitor for this device or something close to that.

I'm going to continue playing around with it. If you get any ideas please let me know.
  • 0



    New Member

  • Member
  • Pip
  • 9 posts
i think i know how to get rid of all of those

problems, if u can run selective startup like Hucklebuck said, then go into ur system32 folder, there are anywhere from 1-3 files called svchost(1's a program others are possibly notpads) replace those with uncorrupted files. this will not work in regular startup mode because the progam svchost is in use. u can delete the notepads, but they just come back unless u got rid of the corrupted svchost

Edited by warwolf0, 19 May 2005 - 05:29 PM.

  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
First off...



Thanks Spank_Me, you pointed me in the right direction and were ultimately responsible for my success.


I'll explain what I think was wrong and what had to be done to fix it.

Once Spank told me about using the Windows System File Checker (sfc.exe) to replace any corrupted system files I got to thinking... "Maybe the printer spooler (spoolsv.exe) is corrupted. Then I just happned to run down my HiJackThis log and see that of all teh services that were running, Spoolsv.exe was the only one that did not have the author listed. It should have said "Microsoft Corporation" instead of "unknown" which is what it did say. I was 90% sure that the spoolsv.exe file was corrupted. How it happened I don't know but I had to fix it. I tried to run sfc.exe like Spank told me to. I had a problem with the system recognixing that I was the computer administrator so I restarted using Selective Startup (msconfig feature). This allowed me to run sfc.exe from the command prompt (Start -> Run -> cmd [enter]). Once this was completed (worked the first time). I had to turn Selective Startup back off and restart in Normal Startup.
Okay, normal startup booted... I checked Windows Taks Manager (Ctrl-Alt-Del), spoolsv.exe is running (awesome). Now I tried to run the Dell A960 Driver Install Program. There was an error in Windows Explorer during the installation which I think bunked things up a bit. The spooler shut back down so I ran sfc.exe again to be safe. Now I restarted to be safe (didn't want another Explorer error to interfere with installation) and I re-ran the driver install program. Drivers installed successfully. I could not see the printer in "Printers & Faxes" though. Apparently the drivers had not completely installed successfully. I tried to install the Printer Software (which installs the drivers as well), I received an error message saying that the "Printer Drivers could not be installed. Specified Print Monitor is unknown." I did a quick search using "Dell Printer Monitor Unknown" and found a thread in another forum about Lexmark printers and how Dell uses their drivers for some of their printers. The forum didn't answer my questions but it reminded me that I had disabled the windows service titled (LexBce Server) back when I was trying to use the Microsoft (lack of ) Knowledge Base to fix the problem (referenced here: http://support.micro...kb;en-us;324757). I had also removed the dependency that Printer Spooler service had on LexBce Server service. I went back into services.msc and started the LexBce Server service. I then re-ran the Dell Printer Software installation program and everything worked out perfectly. Printer is up and running as I type. All seems okay and in order. All I have left to do is reset Print Spooler's dependency on LexBce Server.

This was a pain in the butt to fix but hopefully if someone else runs into a problem like this, this thread will help them out.

[b]Once again, thanks Spank_Me, your suggestion was ultimately the correct answer, I just had to go back and fix all the stuff that I had messed up taking Microsoft's advice before you came along.[b]

  • 0



    New Member

  • Member
  • Pip
  • 1 posts
Had exactly the same problem... Saw that LexBce service was needed, so I figured out to double-click the 'LexBce', turn it to Automatic and then start it. PrintSpool then was able to start!

I didn't do any of the other stuff.

Found this forum via a Google search 'print spooler, services.'

Thanks for the help!

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP