Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

will not read USB key with Code47 error


  • Please log in to reply

#1
vladis12

vladis12

    New Member

  • Member
  • Pip
  • 1 posts
[indent=1][/indent]XP operating system was using my USB copied files verified they we on my machine when tried to go back to the USB drive it was no longer available with the following error "Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47)" telling me to reconnect the device reboo the machine safely remove the hardware and start again.
Assumed I must have jarred it or something follwed the instructions after reboot did the dtandard safe to remove hardware thing removed the device but the USB port will not read that key or any other memory keys keep getting the Code 47 error. This was on my second front USB port, tried in all other ports no cigar. Tried differing varations on the instructions same problem,
The USB driver in the device manager has a yellow fag on it, I tried re installing the driver but it told me that I had the latest driver.

The only wasy I gen get the computer to read any other USB key is to have the original key in the original slot( I have 2 front USB slots) the secnd USB key in the second slot ( computer sees nothing at this time) reboot. System comes up with the eject( safely remove hardware icon) dives E ( original USB device) and drive F are available for the safe removal. When I execute the function to remove Drive F just after the " it is now safe to remove drive F " the new USB drive becomes visible - this is independant of executing the remove drive E function ( E is the original slot with the original problem USB key). Will not work with the originalproblem USB slot.
Looks like something is hung somewhere - How do I reset it.

PS if I reboot with new USB device in old slot recognises new harware but tell me I need to download new drivers for it
  • 0

Advertisements


#2
123Runner

123Runner

    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,307 posts
Hi vladis12 and :)

Go back in to device manager and un-install the USB's.
Re-boot the computer. They will be re-installed and should function.

123runner
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP