Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

External HD Not Recognized. (code 10)

  • Please log in to reply

Kayne Bishop

Kayne Bishop


  • Member
  • PipPip
  • 34 posts

This thing is Driving me crazy and I would like some advice.

I have this Mad Dog Hard Drive Enclosure, with a 40 gig hard disk inside. I have had it for years and it has never given me trouble until recently. I run Win XP on my desktop and I began to notice that when I would boot the system and the mad dog was on, it would take forever for the system to load. When it was off , loading didn't take as long. When I turned the Drive back on it loaded as normal.

That is until yesterday. I wanted something off the drive. When I turned it on nothing happened. I heard the sound that said a device was connected to the computer. I heard the sound that says it was disconnected. but No autorun screen, no acknowledgment, nothing. Clicking the icon for the drive leads to an error message that says there is no such device.

I haf unplugged the poer sours to reset all of the usb drives on the mainboard, no good. I tried to update the drivers, no use . I tried troubleshooting, the troubleshooting screen came up blank. Going through the Device manager, I get a yellow exclamation point. The message in properties box says "This device cannot start. (Code 10) - Click Troubleshoot to start the troubleshooter for this device"

When I plug the mad dog into my laprop (running Win &) i get the same connect/disconnect acknowledgment... but nothing else .

What do I do now ?
  • 0




    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,749 posts
Hate to be the bearer of bad news but, it sounds like a dead hard drive. They are mechanical devices, and as such they do wear out. :) (This is why 'backups' are so important).

First thing I'd try is to remove the hard drive from the enclosure and either connect it directly (internally) to a computer or with a different USB adapter. If it works fine now, your Mad Dog enclosure is dead.

If it still doesn't work though ... yep, you guessed it, dead hard drive. :)

If it is 'dead' and you positively must have the data off of it, Ontrack can probably retrieve it. Note that it can get expensive though.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP