Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Please Help!--Need drivers for unknown audio device


  • Please log in to reply

#1
xlr82scs

xlr82scs

    New Member

  • Member
  • Pip
  • 1 posts
I have a HP Pavilion a6300f desktop which came with Vista Home Premium installed. I didn't care for Vista so when I discovered that some of my favorite PC games were not compatible, I downgraded to XP Pro sp3. I have managed to solve all of my driver issues with XP, except one. I have no sound from my speakers.
In my Device Manager, under Sound, video, & game controllers-I have the yellow exclamation mark next to Audio Device on High Definition Audio Bus. I have tried to uninstall and I get a message that it "Failed to uninstall the device. The device may be required to boot up the computer." When I clicked on 'Update Driver', NOTHING happened. If I right click on the device, open properties, then click on 'Reinstall Driver', again, nothing happens. This is a list of ALL the information listed about this device:

Properties--General
Device type: Sound, video and game controllers
Manufacturer: Unknown
Location: Location 65535 (Internal High Definition Audio Bus)
Device status: The driver for this device are not installed. (Code 28)

Properties--Driver
Driver Provider: Unknown
Driver Date: Not available
Driver Version: Not available
Digital Signer: Not digitally signed
Driver Details: No driver files are required or have been loaded for this device.

Properties--Details
Device Instance Id:
>HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_10EC0888&REV_1001\4&3F30E8C&0&0001
Hardware Ids:
>HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_10EC0888&REV_1001
>HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_10EC0888

Compatible Ids:
>HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&REV_1001
>HDAUDIO\FUNC_01&VEN_10ECDEV_0888
>HDAUDIO\FUNC_01&VEN_10EC
>HDAUDIO\FUNC_01

Enumerator:
>HDAUDIO

Devnode Flags:
>DN_HAS_PROBLEM
>DN_DISABLEABLE
>DN_NT_ENUMERATOR
>DN_NT_DRIVE

ConfigFlags:
>CONFIGFLAG_FAILEDINSTALL

Class Installer:
>MmSys.Cpl,MediaClassInstaller

Current Power State:
>D3

Power Capabilities:
>PDCAP_D0_SUPPORTED
>PDCAP_D3_SUPPORTED
>PDCAP_WAKE_FROM_D3_SUPPORTED

Power State Mappings:
>S0->D0
>S1->Unspecified
>S2->Unspecified
>S3->D3
>S4->D3
>S5->D3
There are 24 headings under the 'Property--Details' tab. Ten of them are listed above followed by the details they contain. The other 14 have no details listed.

For the past week I have searched the web without luck, looking for the drivers that will resolve this issue. I discovered that a lot of people have the same issue but no one seem to have a solid solution.
I even tried a couple of the driver scanners. Uniblue Driver Scanner said I wasn't missing any drivers. The other one listed a Realtek driver file to download but when I tried to install it, I received an error message that it could not install because it was not the correct file.
Will someone please help me???
  • 0

Advertisements


#2
deggitt

deggitt

    Member

  • Member
  • PipPipPip
  • 272 posts
hi, VEN 10EC is Realtek semiconductors.
  • 0

#3
deggitt

deggitt

    Member

  • Member
  • PipPipPip
  • 272 posts
Found this link you could try.

http://ptf.com/hdaud...subsys drivers/



sorry not much more help.
  • 0

#4
deggitt

deggitt

    Member

  • Member
  • PipPipPip
  • 272 posts
hi, my last post not very helpful.

this is what i have found.

your pavillion.. mobo- foxcom MCP73M01H1

audio- realtek hi def audio chipset ALC 888s

you can download Xp drivers from thier site.

http://www.realtek.c...Down=false#High Definition Audio Codecs

could not find this foxcom mobo on foxcom site, it would hve been better to download chipset drivers for this board from foxcom.

hope this is of some help .
  • 0

#5
litefogg

litefogg

    Member

  • Member
  • PipPip
  • 17 posts
If you have installed the ac97 driver and it wasn't the rite one, you'll never fix it, without reinstalling XP. Search it and see, for yourself. SP3 has been a nightmare, for thousands of people,also. Google that. I'd advise to install SP2 and be certain, about getting the correct sound driver, next time. If that don't work, just use a sound card. They are cheap.
  • 0

#6
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
I had the same problem on a friend computer i was trying to fix and I have found out that on some machines made specially for Vista when you install XP the audio devices are not recognize by the system but only as PCI device and even if you install the right drivers for your Sound Card they will not work. Go to Microsoft update and find the driver for PCI device once you find it then your system will recognize your sound card and it will be able to install drivers without any problem.

Hope this will work for you it did for me on a Toshiba L300 and thats how i solved the audio problem on it.
  • 0

#7
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
Hi xlr82scs ... :) ..:)

try reinstalling your chipset drivers...
you can also try getting them from windows updates...use the cutom option and when its done checking...look on the left side for any hardware drivers it says you need...get them all
  • 0

#8
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
Hi xlr82scs ... :) ..:)

try reinstalling your chipset drivers...
nojoy
you can also try getting them from windows updates...use the cutom option and when its done checking...look on the left side for any hardware drivers it says you need...get them all
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP