Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unable to join any multiplayer servers for any game.


  • Please log in to reply

#1
zxcymn

zxcymn

    Member

  • Member
  • PipPip
  • 55 posts
This just started a few days ago; before that everything has been fine.

I can browse the internet fine, talk to people online, etc. the internet works and it's fast. However whenever I try to join any type of multiplayer game it'll list servers but if I try to join one it'll either say it was unable to connect or connect then lag out before I can play. This happens for every single game I try, and four days ago it was all fine.

No firewall is stopping them from connecting. I'm behind the Windows 7 firewall but I always have been and they worked before so that isn't the reason. The only thing that's changed was I created a host through no-ip.com and used their no-ip client, but I've since deleted the host and uninstalled the software. However it seems the problems started around the time I used that; maybe it's related? I'm not sure how that would have any effect though.

Anyway, I'm at a loss as to how my internet can work peachy but no online game will let me connect to them. Any ideas?

Thanks for your time.
  • 0

Advertisements


#2
zxcymn

zxcymn

    Member

  • Topic Starter
  • Member
  • PipPip
  • 55 posts
It's fixed. Just in case anyone else is having this problem:

I had to call my provider to get the actual password for the router (admin/admin won't actually change any settings but will let you log in) and disabled an option to block all foreign ports. My internet is faster and I can connect to everything now.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP