Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Removable Drives Don't Show in Explorer


  • Please log in to reply

#1
Fritzybabe

Fritzybabe

    New Member

  • Member
  • Pip
  • 3 posts
Hi

I have a problem that I have not been able to solve from several weeks of Google searches.

Due to a continual but random BSOD problem I installed XP64 on my PC (that was originally XP32). I installed it on the 2nd of two 750GB dirves and it running fine except that I have a problem with windows explorer not showing a removable drive. This includes any pen drives I insert plus a Lacie 320GB, WD500GB and WD 1.5TB external HDDs.

If I open the Computer Management Console and click on Disk Management they are there with a drive letter. If I open windows explorer from this Console view a small pen drive (upto 4GB) is ok to use (I can upload to it or download from it).

If I open the larger drives in this way I can download from them but if I try to upload to them I get an error message that this volume does not accept long filenames (attached).

I can get all usb removable drives to work correctly by plugging them in before I turn the PC on. They will appear in explorer as normal and I can remove them and re-insert them physically and they will reappear in explorer.

Does anyone have any ideas please?

Fritzybabe

Attached Thumbnails

  • Error_Message.jpg

  • 0

Advertisements


#2
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
Hi Fritzybabe ... :) ..:)


you need to check this registry key and change it if necessary...but first we need to create a restore point...

Manual steps to back up the registry in in Windows XP

1. Click Start, click Run, type %SystemRoot%\system32\restore\rstrui.exe press enter
2. On the Welcome to System Restore page, click Create a restore point, and then click Next .
3. On the Create a Restore Point page, type a name for the restore point and then click Create
4. After the restore point has been created, click Close.

Note If System Restore is turned off, you receive a message that asks whether you want to turn on System Restore now. Click Yes. Then, in the System Properties dialog box, click to clear the Turn off System Restore check box, click OK, and then repeat this step.

when you have completed creating a restore point...

1. Click Start, and then click Run. The Run dialog box appears.
2. Type in regedit press enter
3. Navigate to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Filesystem

4. In the right hand pane, right-click the following value, and then click
Modify:

NtfsDisable8dot3NameCreation

5. Change the number in the Value Data box to 0

6. Click OK.
7. Click Registry, and then click Exit.

reboot and then try the flash drives again

Edited by happyrock, 13 April 2010 - 04:06 PM.

  • 0

#3
Fritzybabe

Fritzybabe

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Happyrock

Thanks for the speedy reply.

I did what you said but the key

NtfsDisable8dot3NameCreation

is already set to 0.

I have attached the all the value for that key.

Fritzybabe

:)

Attached Thumbnails

  • Key_Values.jpg

  • 0

#4
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
what is the make and model of your computer...
  • 0

#5
Fritzybabe

Fritzybabe

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Main Circuit Board
Board: ASUSTeK Computer INC. A8N-VM Rev 1.xx
Bus Clock: 200 megahertz
BIOS: American Megatrends Inc. 0403 10/05/2005

Processor
2.00 gigahertz AMD Athlon 64
128 kilobyte primary memory cache
512 kilobyte secondary memory cache
64-bit ready
Not hyper-threaded

Operating System
Windows XP Professional x64 Edition Service Pack 2 (build 3790)

Memory Modules
Slot 'DIMM0' is Empty
Slot 'DIMM1' has 1024 MB
Slot 'DIMM2' is Empty
Slot 'DIMM3' has 1024 MB

Drives
SAMSUNG HD753LJ SCSI Disk Device (750.15 GB) -- drive 0, SMART Status: Healthy
SAMSUNG HD753LJ SCSI Disk Device (750.15 GB) -- drive 1, SMART Status: Healthy

Display adapter
NVIDIA GeForce 7900 GS
  • 0

#6
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
I'm not sure if it will fix your issue but you have a old bios...there are 3 updated bios's available here...
Please do not update your BIOS via EZFlash. Must update it via AFUDOS or ASUSLive Update....I recommend you use the ASUSLive Update...try Version 0702 2006/02/08 update first...
How to update BIOS here
I'm going to check with other techs and see if they have any idea's I may be missing

Edited by happyrock, 15 April 2010 - 12:27 PM.

  • 0

#7
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
one more thing to try...
click on start...run...type in services.msc...press enter...
make sure plug and play is enabled and set to auto and the service is started
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP