Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Printer won't power on


  • Please log in to reply

#1
shelley8492

shelley8492

    New Member

  • Member
  • Pip
  • 2 posts
I have an Epson Stylus CX5800F. It is several years old, but was hardly used. Now I am using it and it was working fine, then a few hours later, the power button wouldn't come on. Finally found that if I unplugged the power cord and plugged it back in it would work. It worked for a few weeks. It just stopped again. I tried the tricks from before, but nothing is working. It isn't the power cord as I plugged it into another rprinter and it is fine. Maybe an issue with the power button not connecting properly? How can I access it? Any other suggestions? Thanks!

Shelley
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP