Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

HP Photosmart won't install

  • Please log in to reply

Ian W

Ian W

    New Member

  • Member
  • Pip
  • 8 posts
HP Photosmart C6180 connected via wireless router (DG 824M) to Vista Business 32 bit SP2 computer (on wired connection to router).

Has been working for some time.

Tried to do a scan from HP Solution Centre - HPSC said there weren't any devices attached.

Checked router tables - printer had disappeared. Restarted router and printer. Printer now visible. I can even print to it, but HPSC still doesn't see it.

Followed HP advice on website. Downloaded latest AIO software. Uinstalled the then current version and installed newer version.

At point where it detects printers, it found it, picked up the IP address etc, but then, while it seems to be negotiating the model number, it fails with a big red X on the graphic. Continued install for rest of AIO package.

Tried to Add Device from the installer - same result.

Went to Windows Control Panel | Printers | Add Printer.

Windows recognised there was a printer there, picking up the model number, but again, while searching for the appropriate driver, fails and drops me through to the manual - add driver. Select HP, scroll through the list of photosmart printers - there isn't a driver for the 6100 series. It just isn't listed.

Added it as a 7200 series and I can now print again, but HPSC still doesn't see the device as being attached.

Uninstalled, cleaned registry, removed temp files, installed again... Same result.

I can connect to the printer through the browser and run a scan from the on-board web utility. I can print (as a 7200). I've tried with a fixed IP address (which is what it had when the problem came to light).

HP Printer diagnostic doesn't recognise it as connected. HP network diagnostic hangs while trying to discover it.

I have no idea what to try next. Nothing had been altered since the previous time I used it and it worked, other than possibly some windows updates.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP