Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

CD/DVD Drive

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hi, I've been using a Dell Inspiron 9400 for a while and recently the CD/DVD drive has caused me burning issues (it reads OK). It won't burn anything anymore. When I try to burn either an disc image or a set of files as it does normally (and visually I can see the disc has been written on) but still recognize it as an "empty disc" provoking CD verifying errors.

Here are the steps I'd try to do to solve this with no luck:
1. I'd tried different CD brands,
2. I'd tried different burning software such as ImgBurn, CDBurnerXP and the XP built in burning software,
3. I've updated the firmware version (DE04),
4. I'd tried to reset upper and lower filters in the registry in this address: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318},
5. I'd tried to uninstall CD/DVD driver in "Device Manager" and rebooting.

iTunes Diagnostics for the CD reports everything read-wise is OK.
Windows Diagnostics for the CD/DVD drive reports this:

Drive is not capable of burning (TSSTcorp DVD+-RW TS-L632D)
One or more CD/DVD drives are not capable of burning

Class filter drivers are corrupt

Drive is disabled (TSSTcorp DVD+-RW TS-L632D)

Drive is not assigned a drive letter
The CD/DVD drive is not accessible via an assigned drive letter

Drive is not capable of burning (TSSTcorp DVD+-RW TS-L632D)
Detected One or more CD/DVD drives are not capable of burning

I'd previously installed CD DAEMON tools to load disc images and I kind of think it has something to do. I'd uninstalled it then.
Thanks for your time, your help is greatly appreciated,

Edited by Merthod, 26 April 2010 - 06:44 PM.

  • 0




    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,749 posts
New CD/DVD burners start at $24.99 with free shipping:

http://www.newegg.co.....Free Shipping

  • 0




  • Member
  • PipPipPipPip
  • 1,939 posts
Yeah, new burners are pretty cheap now days so I generally don't spend much time on them either. Here is my canned. Basically, if none of the below recommendations work, then your drive is dead/faulty.

1. Uninstall the drive through the Device Manager
  • Click Start (in Vista/7 Click Windows Orb)
  • Right Click My Computer
  • Select Properties
  • Click on the Hardware Tab (In Vista/7 click Device Manager in top left corner)
  • Click Device Manager
  • Expand DVD/CD-ROM drives
  • Right click your drive
  • Select Uninstall (see image below)
  • Restart your computer
The drive will automatically be reinstalled

Posted Image


2. Go to Microsoft's Fix
  • Choose your Operating System's fix
  • A restart is required

3. Download Restore Missing CD Drive patch
  • Double Click cdgone.zip to unzip it(extract all files)
  • Right Click cdgone.reg
  • Click Merge
  • Accept the registry merge
  • Restart your computer

4. Go to the Device Manager (similar to option 1 above)
  • Expand IDE ATA/ATAPI Controllers.
  • You'll see two items:
    - ATA Channel0 (or Primary Channel)
    - ATA Channel1 (or Secondary Channel)
  • Right click on each of them
  • Select Uninstall
  • Confirm it
  • Restart your computer
They'll automatically be reinstalled.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP