Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Zen X-FI MTP Problem

  • Please log in to reply




  • Member
  • PipPipPip
  • 511 posts

Just plugged in my new Zen X-fi 16GB MP3 and it came up with the new hardware found dialogue. Im using XP Pro 64Bit just to let you know :)

I have tried tons of times to install it using the cd, using the software from the creative website, tried uninstalling WMP11 and reinstalling it, tried restarting the system...no luck what so ever :) All it says is "Cannot install this Hardware..." Below that it says MTP Device with what looks to be a small mp3 player icon.

I have been trying for the past 2 hours with no luck what so ever...what am I doing wrong?

Cheers :)
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP