Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Goodmorning macbook... lets go in the internet.. What the... WE CANT?


  • Please log in to reply

#1
wooooop

wooooop

    New Member

  • Member
  • Pip
  • 3 posts
Kiaora guys

So I'm living my life enjoying my fantastic macbook... first day I bring it home I open it up, bang it automatically connects to my home wireless internet i didn't have to look at any settings etc (so i don't know what the correct settings actually look like :) ) but then after a while i put it to sleep for the night, opened it up and woah internet is no longer working!
So i have a peek at the network settings and i get
Airport status: On
Airport has the self assigned ip address 169.254.xxx.xx and will not be able to connect to the internet.
Which i can't. Which sucks.
The airport thingy up the top is faint with an exclamation mark over it... I have a tick next to my home wireless network so like im connected or whatever but it also says Alert: No Internet Connection.
I have other devices connected fine to my wireless network and accessing the internet so im pretty sure its just some settings on my macbook got messed up or whatever, if anyone could help me out i'd really appreciate it!
I tried all the old tricks of resetting the wireless network.. turning airport on and off.. restarting computer.. running the assist me/diagnostics thing all to no avail.. tried disconnecting and reconnecting to my network.. can't get anything to go!
However if I take my laptop with me to uni I can connect wirelessly to the uni network fine.....
so thats the situation, if you need more details just ask and if you can help you're a king among men!\
im posting on here because i can't afford to ring the bloody toll line for mac support that they have in NZ ;\
cheers guys!
  • 0

Advertisements


#2
Matthew C. Miller

Matthew C. Miller

    Member

  • Member
  • PipPipPip
  • 116 posts
Ok, so it sounds like you're getting a good wireless connection, which is the radio level connection. But once the wireless is connected, your Mac also has to get a network address from the wireless router, which is the step that's not happening. When you see a 169.254.x.x address, it means your machine tried to request an address, but didn't get an answer and assigned itself a default address.

To correct this, try these in order. This assumes you have OS 10.5 or 10.6 - if older let me know and I'll repost with appropriate instructions for those preferences.
  • Re-request an address on the Mac
    • On the Mac, open System Preferences (Apple Menu -> System Preferences, or via the Dock icon with gears)
    • Select the Network item
    • Make sure your Airport is selected in the list on the left
    • Click the Advanced button, lower right
    • Switch to the TCP/IP tab, across the top.
    • Click the "Renew DHCP lease" button on the right. And wait. And wait. If you see 169.254.x.x show up again, don't despair for another 2 minutes :) because it sometimes takes a little while to complete. After 2+ minutes without an address, or with a 169 address, we can be sure that it won't get an address.
  • Reset your wireless router and try again
    • Turn off or pull the power out of your wireless router. This may be a cable-modem, a dsl modem, or a separate box. Let it sit 15+ seconds.
    • Turn on or plug it back in, then repeat step 1
  • If that's still not working, you could try removing and re-joining the wireless network:
    • On the Mac, open System Preferences (Apple Menu -> System Preferences, or via the Dock icon with gears)
    • Select the Network item
    • Make sure your Airport is selected in the list on the left
    • Click the Advanced button, lower right
    • Select your network in the "Preferred Networks" list, then click the "-" button below to remove it.
    • Close the preferences and re-join your network via the Airport menu
If that doesn't fix it, you may have a problem with the wireless router itself and may need to contact your ISP for configuration support.

Let me know how it goes!
  • 0

#3
wooooop

wooooop

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thanks for your help, although problem still not solves after giving those a go! I have thought about it being a problem with my ISP or wireless router.. you see i have the D-Link 502-t modem that my ISP gave me.. and my PC is plugged into that... and the wireless is plugged into that modem too which is one that we bought. However our ISP says since we have internet it is not their problem.. and that the wireless modem is not one that they gave us so they can't help us with it and told me to call belkin which is the make of my wireless modem. I call belkin and they say its not a problem with the wireless since other devies can get it and that it must be a problem with my macbooks settings! arg! any more ideas anybody?
  • 0

#4
diabillic

diabillic

    Member 1K

  • Member
  • PipPipPipPip
  • 1,370 posts
Are you using WEP/WPA on your network?
  • 0

#5
wooooop

wooooop

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
ummm not totally sure what you mean there.. but when in network settings under preferred network it has my home network and then security : WEP password, is that what you mean?
  • 0

#6
diabillic

diabillic

    Member 1K

  • Member
  • PipPipPipPip
  • 1,370 posts
Yes thats what I mean. Try deleting the network out of your keychain and then reconnecting to it.
  • 0

#7
trucker

trucker

    Member

  • Member
  • PipPipPip
  • 231 posts
sorry for the cross post , I have the same thing going on also no net.Ive also gone thru all these steps reset router rejoined network. linux and windows both ok.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP