Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

CD/DVD Rom Drive not reading some discs....

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts

*computer novice at work ~ Please be patient!*

I just got a new graphics tablet for my birthday, nice. I'm trying to install it using the brand new disc that came with it. However my disc drive doesnt like the new disc. I was running Windows Vista Home Premium (sp1 32bit) on an Asus F5 entertainment system, the disc drive is a Matshita DVD-Ram UJ870QJ ATA. I can't use SP 2 because it hates my internet dongle

First off I just popped the disc in and waited for it to auto install, nothing happened, so I went to my computer, clicked on my F: drive and nothing happened. It wont even open the window where you can look at whatever files are on the disc. Well it tries but it just closes straight away.

I've tried other discs in the drive, some work some don't. Anything I burned myself works fine, stuff I burned on other computers works fine, all my backup discs work fine. DVD's and CD's are maybe maybe not, some work some dont, and anything at all that came with hardware doenst work at all!

I've tried rebooting, turning off my firewall and virus thingie, shouting.... nothing happens, I can hear the disc clunking and spinning but I can't access any of the info on it! I've also tried uninstalling the drive and rebooting, the drive re-installed automatically but I still cant get it to read the disc. I updated the drivers too.
I also ran a thing off the microsoft website to check for errors, it told me it detected some problems with my system but could not successfully apply all of the fixes, apparently the media in the CD/DVD drive is not readable, the drive is empty or the format is not supported.
Next I tried posting in a different help forum and was advised to check my ASUS updates were up to date, I did that, no joy. Everything is up to date and my disc still wont work.
Next I tried re-installing SP2, that didnt work.
Finally I had another google and found that a few people were havig a problem with the drive not being recognised so I followed the instructions to delete the upper and lower filter values. I rebooted and popped the disc in and it started to load. Some 5 minutes later windows crashed. It asked if I wanted to retry and I clicked yes, I got a pop up message saying I needed to download shockwave 11 (?) and to click to download it, I clicked and my browser began to open a new tab and bugger me! SP2 throttled my internet connection and my laptop froze up again. I rebooted once more and now the disc wont load again! *scream!*

Help Please! I've been at this for the last 48 hours and I'm starting to go a bit potty. :)

Appologies if I'm in the wrong forum!
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP