Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Epson Printer issues


  • Please log in to reply

#1
shelley64

shelley64

    Member

  • Member
  • PipPip
  • 22 posts
Power went out for 10 seconds. Epson Stylus 2200 won't print at all - no test page or anything - just get printing error. Have unplugged and rebooted, still nothing. Epson Stylus CX5800F did work after power outage, but later in the day get same printing error through the computer. I have unplugged, rebooted and reinstalled. Both printers are in surge protectors and 2200 is in UPS. Have discovered that when starting up 5800F, cartridge moves left to right no problem, but when I tell it to print, cartridge moves to left and stops when told to copy. Printer just says printing. I also cannot turn off printer without disconnecting power. Quick help appreciated as I have a print job to get done and now have lost two printers, one hwich is way too expensive to be a doorstop. Thanks
  • 0

Advertisements


#2
3quilibrium

3quilibrium

    Member

  • Member
  • PipPipPip
  • 137 posts
shelley64,

I would try checking Epson's support knowledge base first to see if there is a resolution for your particular problem. Here is the link to their support page, just enter the model of your device in the search field Epson Support. If you are willing to reset your printers back to factory defaults, I would do some research in Epson's support knowledge base on how to do so, as resetting back to factory settings could get you back up and running.
  • 0

#3
shelley64

shelley64

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
Thanks, I have already tried their KB and did a google search and anything else I could find.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP