Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

My internet should be fine -- but it's not.


  • Please log in to reply

#1
MJRevell

MJRevell

    Member

  • Member
  • PipPip
  • 50 posts
I have just had the BT man round, and he tested my line, and said it was fine. With his gizmos, he got speeds of around 2MB -- which is about the best we can get here. It should be around 2.5, but 2 is good enough.

However, when I try and use the internet it is so slow that it's like pre-historic internet. For the last three days, it's been horrible.

A speed test shows a download speed of: 132kbps and an upload speed of: 345kbps

Currently, it takes about 10 minutes to load up a three minute YouTube video.

If you have any idea what the problem could be, and how I can go about remedying it, it would be much appreciated!
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Contact your internet provider.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP