Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Linksys router (WRT54G2) won't work with modem


  • Please log in to reply

#1
Jesse817

Jesse817

    New Member

  • Member
  • Pip
  • 8 posts
Hi,

I have been having a problem with my Linksys router ever since my old modem stopped working and we bought a new one exactly like the old one. Well we put in the CD installer and the modem works. Next we plug the modem into the router, and the router does not send any internet. :)

Well, I have tried many things to fix it, like having a online chat with a linksys lady, she was not very helpful, she told me to call an 1-800 number, so I called, she doesn't offer any help as well. Then I tried their "5 Star online website", and I had the same result with their coworkers. Next, I went online and was desperately looking for answers, I have tried many things, but the router was being very evil to me. Nothing worked. :)

My notes:
Modem: Motorola Modem Style MSTATEA It works connected to computer :)
Router: Linksys WRT54G2 Version 1 Doesn't work when connected to modem and computer


This is a ipconfig /all to the modem separately, and router separately. :)


Modem
Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Jesse>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : carolina
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-12-3F-B7-23-81
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 70.247.97.71
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 151.164.182.11
DHCP Server . . . . . . . . . . . : 192.168.1.254
DNS Servers . . . . . . . . . . . : 192.168.1.254
Lease Obtained. . . . . . . . . . : Friday, July 09, 2010 7:09:33 AM
Lease Expires . . . . . . . . . . : Friday, July 09, 2010 7:19:33 AM

Router :)

C:\Documents and Settings\Jesse>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : carolina
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-12-3F-B7-23-81
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 192.168.1.254

C:\Documents and Settings\Jesse>

Please, I have done almost all that I could think to do on this router, I am ready to break it, and buy another one :)
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
is this a new router or is it an older one that was working with the old modem? do you recall setting up any custom settings the first time? is the connection DSL, Cable, or some other broadband service?

try resetting the router to factory defaults. unplug the power from the router, with the power unplugged hold in the reset button (little red button somewhere on the back of the router), continue to hold that button in while you plug the power cord back in, hold the button in for 30 seconds more and let it go. the lights on the router should blink a few times and then go back to normal.

any change?
  • 0

#3
Jesse817

Jesse817

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Thank you for replying really quickly, this is the old router, I never bought another one, but it is frustrating me and im thinking about buying another.

This is the only router I have that is working with my new modem. I am not sure about any custom settings, my older sister did all of the installing. I have AT&T and I have DSL (I don't know, sorry). :)

But I have already performed the reset to factory settings, I have done it three times, and I would use the Cd to install it repeatedly.

I have also tried to look at the forums in the linksys website, look up at various websites to see if anyone had any problems like mine, but no luck.

What I have done to it
On July the 8th, or yesterday, I restarted it, installed it with a CD, gave it a new name and a new password, tried connecting it to the internet, but nothing happened. Then I did a ip release and ip renew, no internet. Then I cloned the MAC address, but still nothing.

I think all I need is to plug some numbers in the router's web based setup page and it will work. :)

Thank You dsenette for the quick reply.! :)
  • 0

#4
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
if you've got DSL with AT&T then you need to change the router and your modem's config to accommodate the setup. if you go to the AT&T support page they've got detailed instructions on how to configure the modem into "bridge mode" and how to put in your DSL authentication info into the router.
  • 0

#5
Jesse817

Jesse817

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Thanks dsennette, for another quick reply, I will try to see if this works.
Thank you, Mighty Technology God :)
  • 0

#6
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
What model of modem are you using?

Is your computer set in a DMZ?
  • 0

#7
Jesse817

Jesse817

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
My modem is a silver Motorola 2210-02-1002,

I do not know what a DMZ is, sorry.
  • 0

#8
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
If you have set the user name and password in the modem you just need to change the router's ip address.

To change the IP you need to open a browser. In the address bar type in 192.168.1.1 and log in to the Linksys. If you set a password use that, if not the default password is admin (no username).

Once your in It should look like this. The Internet connection Type should be Automatic-DHCP. Set the Router IP to 192.168.5.1 and save the changes. This should allow the router and modem to talk to each other.
  • 0

#9
Jesse817

Jesse817

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Thanks for your help Silverbeard, I tried this, couldn't figure out the routers IP, this is before I changed it to 192.168.5.1, so I restored it to its factory settings, installed it, changed the router ip to 192.168.5.1, Ip release and ip renew in the Command Prompt, but the router still doesn't want to talk to the modem. (It doesn't connect to the internet) :)

Thank you again Silverbeard, but this router is just sooo frustrating to use. Grrrr :)

I appreciate all your help and advice, you all mighty lords of networking :)
  • 0

#10
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
Open a browser and type in 192.168.1.254 and see if you can get to the modem interface.
  • 0

Advertisements


#11
Jesse817

Jesse817

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Yes, I can. :)
I also figured out that I have DSL, from AT&T
The router is Linksys WRT54G2 Version 1
  • 0

#12
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
This tells us the modem and the router are talking to each other. Open a Command Prompt and try to ping google.com
  • 0

#13
Jesse817

Jesse817

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
I can access the modem interface with the modem connected directly to the computer, when the modem is connected to the router and then the computer, it doesn't get internet :)
  • 0

#14
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
Reset the router. DO NOT RUN THE CD!!! Log in to the router and set the IP. See if you can surf.
  • 0

#15
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
http://www.att.com/e...i...&ct=9000174 from AT&T support, it's suggesting that you don't need to muck with the modem, but you do need to put your PPoE settings into the router
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP