Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

problems with new graphics card pro/660


  • Please log in to reply

#1
dogbiscuit

dogbiscuit

    Member

  • Member
  • PipPipPip
  • 149 posts
Hi
I have just bought a new graphics card as I found that 'Fifa 2005' wouldn't run at all on my old one as it was only 16mb. So I went for the gainward fx powerpack pro/660 128mb DDR. Fifa now runs, but very badly. The graphics look really bad with weird colours everywhere and writing missing from menus, etc. The sound is fine though so I'm assuming this is just a graphics problem. I have also found that 'hitman' which worked fine on my old card is not working now. The game starts with sound working fine but the screen is just black.
I have tried updating the drivers but that hasn't made any difference. I have direct x installed. My pc spec suggests that both games should run fine as I have checked with the minimum requirements on both games.
Unfortunately I'm not too wise when it comes to graphics and really need some help with this. Any help would be much appreciated.
Craig
  • 0

Advertisements


#2
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
did you uninstall the drivers for your old card, and then install the latest drivers for the new card?
also, go into device manager, see if you have any red X's or yellows !'s. look under display adaptors, and system.
  • 0

#3
dogbiscuit

dogbiscuit

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
Yes I went into the control panel> add remove program and uninstalled the old driver that way. Then I installed a new one from the nvidia site. I have checked in device manager and there doesn't seem to be any red x's or yellow !'s.
  • 0

#4
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
ok, sounds like the you did the drivers correctly. check your display settings in the games. try turning them down to 800 x 600, with medium detail settings. if they still dont work with that, then its could be the card...

is this an AGP 4x or 8x card? try going into BIOS, check your agp settings, tell me what they are.
  • 0

#5
dogbiscuit

dogbiscuit

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
I have tried changing the settings in fifa and that doesn't seem to make any difference. I went into my BIOS to check my settings but couldn't find what I was looking for. However, in 'PCI/Plug and Play setup' I found the primary graphics adapter was set to 'PCI'. I tried changing it to 'onboard AGP' but that made no difference. The card supports AGP 2x, 4x and 8x. Could it have something to do with the fact that the card is DDR and my CPU isn't?
  • 0

#6
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
whats the make/model of your motherboard? I want to look in the manual for it, find where the agp settings are.

the ram on the card doesnt really interact with the processor. the card ram stores images and textures, so that it can be accessed and drawn very quickly when its needed. accessing it from the card is much faster than having to go to the hard drive and retrieve the info.
also, the newest video cards are using DDR3 ram, and that doesnt cause compatibility issues- no pc is using ddr3.
  • 0

#7
dogbiscuit

dogbiscuit

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
Hmmm. I will have to look into this because I don't know what make my motherboard is. I bought this pc secondhand and I don't think I got a manual with it, which is rather annoying.
Looks like I might have to stick my head inside it to try and find out the make.. unless there's an easier way!?
  • 0

#8
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
you can open it up, and its usually labeled on the mobo.
or use this tool called everest home edition. it will list all your system specs.
  • 0

#9
dogbiscuit

dogbiscuit

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
Ok thanks for that. I used everest and here's my motherboard details:


Version EVEREST v2.00.335
Homepage http://www.lavalys.com/
Report Type Quick Report
Computer SKYNET
Generator craig
Operating System Microsoft Windows XP Professional 5.1.2600 (WinXP Retail)
Date 2005-05-24
Time 20:57


--------[ Motherboard ]-------------------------------------------------------------------------------------------------

Motherboard Properties:
Motherboard ID 62-0913-001131-00101111-071595-SiS730S$M810LR_RELEASE 09/13/2002 S
Motherboard Name PCChips M810LR

Front Side Bus Properties:
Bus Type DEC Alpha EV6
Bus Width 64-bit
Real Clock 100 MHz (DDR)
Effective Clock 200 MHz
Bandwidth 1600 MB/s

Motherboard Physical Info:
CPU Sockets/Slots 1 Socket 462
Expansion Slots 2 PCI, 1 AGP, 1 AMR
RAM Slots 2 SDR DIMM
Integrated Devices Audio, Video, LAN
Form Factor Micro ATX
Motherboard Chipset SiS730S

Motherboard Manufacturer:
Company Name Elitegroup Computer Systems
Product Information http://www.pcchips.c...nuID=16&LanID=0
BIOS Download http://www.pcchips.c...nuID=35&LanID=0
  • 0

#10
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
hmmm...I couldnt find that exact model on the website. I looked at a similar model, looked through the bios settings, and like you said, didnt see anything relating to agp.
I have asked for someone else to take a look at this. hang in there, we should be able to figure this one out.
  • 0

Advertisements


#11
dogbiscuit

dogbiscuit

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
Thanks audioboy. I'll hang in there. :tazz:
  • 0

#12
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
alright, we have had much trouble finding the right book for that mobo. can you open the case and look for a motherboard model #?
is it correct that this is a micro atx board?
also do me a favor, right click the my computer icon, go to properties. under the general tab, at the bottom it should list the processor type and speed. also the amount of ram. give me those specs too.
  • 0

#13
dogbiscuit

dogbiscuit

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
I don't know if it is a micro atx motherboard. I have had my head in the case and can't find anything at all. I examined it for ages and couldn't find any brand name or model type or anything. The guy I bought it off said it was a custom pc but I'm not exactly sure what he meant by that. The only thing I found was 'titan' on the fans and one of these is attatched to the motherboard but I'm assuming this is just the make of the fans.
Here's my specs: AMD Duron
1.29GHz
256MB RAM
  • 0

#14
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
you mentioned its a custom PC, is it in a small case? compared to a normal size desktop...
its looking like your motherboard is pretty limited, from the similar things we could find online. the fact that you dont have any control in BIOS over AGP settings is not encouraging.
do you have any type of program that will allow you to adjust settings for your graphics card? these can often be found along with drivers at the websites.
I think if your going to have any luck getting this displaying correctly, your going to need to tweak settings thru that, find something that works.
with the hitman game, you may just need to have it redetect your hardware, since you changed cards on it. redo your display settings in that game and it may start working again.
  • 0

#15
dogbiscuit

dogbiscuit

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
I'd say my pc has a pretty average sized case, if anything a little big. I can get settings up for my card by right clicking on the desktop and I have tried various different settings out but nothing seems to make any difference.
As for hitman, I don't know how to change any settings in the game as the screen just goes black as soon as I launch the game. I tried installing a new game (lord of the rings) to see if it would work but it's just the same as hitman, black screen but sound works fine. I have tried changing several settings in fifa but none make any difference.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP