Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Graphic Card + Shader


  • Please log in to reply

#1
NotmeButyou

NotmeButyou

    Member

  • Member
  • PipPip
  • 10 posts
I have a Ati Radeon HD 4650 and it should normally support shader model 4.1 but now it suddenly wont support any kind of shaders so i cant run any kind of program that needs it.
I also have the newest driver installed.

I sometimes get the message that the driver and card maybe aint compatible build (630), or i get the message that My graphics card or driver wont support shader xx, and that i should ensure that my card enables it and that i have a driver from the manufacturer.

This happened like 4 days ago, im not totally sure, but at least 1 week ago i could use the same programs i now cant.
I have no clue whatsoever to do.

Please help.
Thanks.
  • 0

Advertisements


#2
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
There is 3 version of the Ati Radeon HD 4650

1- Integrated
2- AGP
3- PCI-Express

Which one is yours?

If it is an integrated then you should use the Manufacturer of your motheboard, computer for the Drivers (Dell, HP. ACER, ASUS Gigabyte ect.) made for your OS

If it is and AGP or PCI-X then get them from AMD/ATI or OMEGA DRIVERS

Make sure to uninstall all your current drivers before installing new ones.

Hope this helps,

Edited by Alzeimer, 24 July 2010 - 03:43 PM.

  • 0

#3
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
As far as i know its neither of those 3.
It just says PCI. Not express.

I currently use the newest driver from ATI, not sure if its installed properly, or the first one uninstalled properly, when i open up the properities it says that the driver is dated 31.12 2008. Not sure what it means.

Maindriver: atidxx32,atidxx64.dll,atiumdag somthing something
version: 7.15.0010.0163
date: 31.12.2008 14.24.28
WHQL-logo: yes
DDI version: 10.1

Not sure if this is relevant.


The weird part is that i didnt tamper with anything, it just suddenly stopped supporting Pixel shaders. Been advised to install directX 10 by somefolks, but i have DirectX 11.
Running Vista x64 Home Premium SP 2
  • 0

#4
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,035 posts
Have you checked the actual card manufacturers website for the latest
drivers (Sapphire, Powercolour etc) they sometimes have their own version
of drivers & hotfixes.
  • 0

#5
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
http://game.amd.com/.../common-vista64

These are the latest ATI Radeon HD 4650 driver version (10.6) for Vista x64 (dated 6/16/2010)

Please be sure you do not have an integrated video card if you install these drivers, if you do then you will need the drivers from your board/brand manufacturer.
  • 0

#6
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
It didnt solve the problem.
And it sounds weird to me that a driver that did support something suddenly stops without me touching it.

Any viruses or some vista background stuff, or anything that could do it?
I tried the system recovery thing but I only get an error.

Possibly only thing i can do is to reformate the hd and reinstall Vista.

When i bought the computer i could just turn it on and install vista without any cd. When i reformate, will it do the same? or do i need to get a cd`?
  • 0

#7
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Actually, after bumping into this site thingy called, Can You Run It? http://www.systemreq...ntslab.com/cyri
It shows what games you can run with your current system.

I choose a bunch of random high requirement games and come up with these things that isnt provided.


Video Card
Minimum: DirectX 9.0 capable video card support Shader 2.0 << I have DirectX 11
You Have: ATI Radeon Graphics Processor (0x9480) << Not sure what this is....?
Pixel Shader version 2.0 Have 4
Vertex Shader version 2.0 Have 4
3D dont have
Hardware T&L dont have

So i guess the problem lies in the 3D part and the Hardware T&L part. I did run this game 2 weeks ago so my system should have both.


You Have: ATI Radeon Graphics Processor (0x9480) << Not sure what this is....?
Any idea what this is?


And i have been searching around a little and noticing that other people with the same computer model and hardware and driver as me is running the games flawlessly only having slight problems with the Frame rate from time to time.

Edited by NotmeButyou, 25 July 2010 - 10:37 AM.

  • 0

#8
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,035 posts
Please post your computer details this will enable others to help you better.
Is your computer by any chance a laptop?
  • 0

#9
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts

Please post your computer details this will enable others to help you better.
Is your computer by any chance a laptop?


okies,

It is a laptop
HP Pavilion dv7-2135eo Entertainment Notebook PC

Think you can google that line

And i found out that my video card is integrated so i went to HP's driver update site and installed the newest driver/CCC, and with CCC i used the update function to make it the newest driver availiable.

Attached Files


Edited by NotmeButyou, 25 July 2010 - 11:48 AM.

  • 0

#10
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Running system information i find i have 2 video drivers installed

AMD multivendor miniport driver
ATI radeon kernel mode driver

That supposed to be that way?
  • 0

#11
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,035 posts
Is this the page you found http://h10025.www1.h...985390&sw_lang=
Download the drivers to your laptop then uninstall the present
drivers and reinstall them afresh, this will avoid conflicts.
It also suggests to update to the latest BIOS to fix various
gfx problems, I hope this resolves the issue for you.

Edited by phillpower2, 25 July 2010 - 12:15 PM.

  • 0

#12
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
This is the page i found with the components of my pc.

http://h10025.www1.h...product=3985390

I have done the reinstalling of my drivers part and they are newest version but still i can run any 3D stuff.
At Catalyst Controll Center, when i try to load the options on 3D, the moving 3D pictures wont show. It just stands Loading.


Any chance that this could be some directX issue or something?

when is search for DirectX i cant find anything concrete so maybe i have deleted it somehow but my computer aint noticing.


And again i dont know what in the world could be wrong with the drivers since it worked earlier without me changing any driver.

Edited by NotmeButyou, 25 July 2010 - 12:39 PM.

  • 0

#13
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,035 posts
Couple of suggestions;
1:Have you tried going into dxdiag and enabling D3D
2:Go to add remove programmes and delete anything
related to DX11, install DX10 from here http://en.kioskea.ne...1-directx-vista
Some info here on DX11 for what it is worth;
http://www.notebookc...50.13883.0.html
  • 0

#14
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Il try those, as for D3D thing, my dxdiag doesnt have any buttons that can enable anything.
Might be because of my OS i dont know.
All i can do is read the information, save the information, or enable x64dxdiag.


As for
DirectX 11 is integrated in my OS and cant be uninstalled separativly :)

Edited by NotmeButyou, 25 July 2010 - 01:51 PM.

  • 0

#15
NotmeButyou

NotmeButyou

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Problem partly solved.
New problem arrived so il make a new thread.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP