Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

SLI causing graphic problems in games


  • Please log in to reply

#1
Novaprospekt

Novaprospekt

    Member

  • Member
  • PipPip
  • 66 posts
Hi guys,

So I am having an issue (re-emerge) with my two GeForce 8800 Ultras (512MB, identical cards) in SLI mode. When I open up a 3D application, in this case Starcraft II, I get weird grainy graphics (like 8-16bit colors almost). The grainy/bad colors flicker periodically when the display changes (such as navigating a menu or loading a game) to normal good looking graphics. I had gotten this problem in the past when trying to play World of Warcraft and I don't remember how I got the problem to go away (could have been drivers, disabling SLI outright, or anything really -- it was a long time ago).

I had the 2nd card disabled and had not played any 3D games for almost a year since I had to focus on school work but when I re-enabled the card and turned SLI back on last night it caused the problem to return.

Each card has been tested independently and works properly. When I disable SLI in NVIDIA control panel, the graphics return to normal. Even oddly enough, I got the graphics to display normally when I changed a setting in the NVIDIA control panel that I think effectively neutered the benefits of having two cards in SLI: I changed SLI performace mode to "single-GPU" under manage 3D settings. I am not sure but I think it was originally on alternate frame rendering.

SLI indicates that it is active in the actual "SLI options" section of the control panel and I don't have any one card dedicated to physX processing either (it's set to auto).

Drivers are current too.

I would provide a screenshot but I am typing this at work and don't have one on hand right now but can provide one later if need be.

Any ideas what this could be?

Thanks guys


Hardware specs:
ASUS P5N-E SLI Mobo
Intel Core 2 Quad 2.4GHz
4GB DDR3 RAM
Dual 160GB 10k RPM WD Raptors in RAID0
Dual GeForce 8800 Ultras 512MB
Soundblaster X-Fi Fatal1ty pro series sound card
  • 0

Advertisements


#2
Fenor

Fenor

    Trusted Tech

  • Retired Staff
  • 5,236 posts
Hi Novaprospekt!

SLi currently doesn't work in SC2, and disabling SLi is the only way around it. I have no idea if it will support it or not in the future, but I highly doubt it. World of Warcraft still doesn't support it after almost six years. Blizzard likes to make games that are playable on a wide-range of PCs, and therefore, they disable (well not disable on your end, but make their games not use them) most advanced features of systems to do that. Just go into the Nvidia Control Panel and set up a Profile for Starcraft II to only use one video card. That way, when you start up the game, it will automatically only use one video card, making it so you don't have to manually do it yourself each time.

Keep an eye out, and keep reading all new patch notes for the game, because if SLi does become supported, it will most definitely say that in the patch notes.

Fenor

Edited by Fenor, 30 July 2010 - 08:04 AM.

  • 0

#3
Novaprospekt

Novaprospekt

    Member

  • Topic Starter
  • Member
  • PipPip
  • 66 posts

Hi Novaprospekt!

SLi currently doesn't work in SC2, and disabling SLi is the only way around it. I have no idea if it will support it or not in the future, but I highly doubt it. World of Warcraft still doesn't support it almost six years. Blizzard likes to make games that are playable on a wide-range of PCs, and therefore, they disable most advanced features of systems to do that. Just go into the Nvidia Control Panel and set up a Profile for Starcraft II to only use one video card. That way, when you start up the game, it will automatically only use one video card, making it so you don't have to manually do it yourself each time.

Keep an eye out, and keep reading all new patch notes for the game, because if SLi does become supported, it will most definitely say that in the patch notes.

Fenor


Hi Fenor,

Thanks for clarifying that for me about Blizzard and SLI. So I assume if I am trying to force SLI to run (alternate frame rendering) in a 3D application like SC2 it would cause the graphic anomalies I described? I guess if the game doesn't utilize SLI then I don't mind not having it enabled. And hopefully, single-GPU mode still makes use (in part) of my second card by shunting any extra load from the primary card to the secondary card as some have hinted at to me.

I suppose the true test if my SLI works properly would be to try a 3D application that supports it. I have to check if Bioshock 2 does because I think I had both cards working for that unless I'm totally delirious right now.

Anyway, thanks again!!
  • 0

#4
Fenor

Fenor

    Trusted Tech

  • Retired Staff
  • 5,236 posts
SC2 is mainly CPU based (as it has to actively track all the moving units on the screen, calculating attacks, collisions, etc.), so the only bottleneck you would get is if you are using a lower-end processor. Otherwise, your 8800 is more than enough to run it.

And yes, Bioshock most definitely does, as FPS (First Person Shooters) are mainly GPU based, rather than CPU based.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP