Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Missing Volume Control In Tray And No Audio Tied To Microsoft Audio


  • Please log in to reply

#1
CactusBill16

CactusBill16

    New Member

  • Member
  • Pip
  • 2 posts
Hi
I'm having some odd audio problems. I recently worked through removal of a bad malware infection that did affect my volume control. However, the infection was cleared and everything was working okay. The support person then had me do some followup to try and protect the machine from future infections. Sometime during this process my volume control icon in the system tray disappeared. I have tried all the fixes to try and reestablish the volume control to the tray, even reloading the sound file from my XP disc, with no success. Also, Windows Media Player no longer functions properly. If I try and play mp3 files it says I'm missing a codec. I downloaded and upgraded to WMP 11 thinking that would restore any missing codecs, but with no success. Also, I do not receive audio on many streaming sites like YouTube and streaming radio stations.

On the other hand I can play everything through iTunes and I downloaded the VLC media player and it works great. But, the sounds associated with the Microsoft system no longer play, such as the bootup and close down tunes and sound affects that play with many of the software programs loaded on my machine.

Any information would be helpful. If I have to reload codecs maybe you could recommend a safe site to obtain the codecs and the proper process to reload the codecs.

Thanks,
CactusBill16
  • 0

Advertisements


#2
CactusBill16

CactusBill16

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
I knew the sound on my system was basically okay, since I could listen to everything in the VLC player.

However, the fix for my sound problem was really simple but the answer was just very complicated to hunt down.

I noticed that a lot of the chatter about similar problems on other forums was tied to Adobe Flash Player.

One of the last things the support person had me do after ridding my computer of malware was have me uninstall all my old Adobe software and reinstall all the latest versions. I just didn't make the connection that Adobe software could affect all the Microsoft sound.

Finally after doing a Google search on Adobe Flash Player sound problems I found the solution:

Here is an actual quote:

Alright the problem is really the mapping of wavemapper in Windows registry as reported by one member of the forum.

All you need to do is to open registry editor by going to Start menu, Run, typing regedit and then Enter.
After that, in the registry editor, walk yourself through the tree in the left pane, till you reach

My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

And then on the right pane, right click and click on New, select String value, enter "wavemapper" (without quotes of course), ENTER, type "msacm32.drv",
ENTER.



Well, of course it didn't work the first time. I received this message:


the registry editor cannot rename New Value #1. The specified value name already exists. Type another name and try again

I was stumped for a time until I saw somebody in the forum with a similar problem mentioned they had found a fix for this problem by granting subkey permissions. This led me back to Google searching for registry permissions.

After that here is what I had to do, and although it seems like a lot of steps, it is really quite simple:

Once I had reached the drivers32 registry entry I highlighted the entry in the right pane. Mine said (Default) REG_SZ (value not set). I then clicked on Edit in the Menu bar and clicked on permissions in the drop down.

This opens the Permissions For Drivers32 window. I highlighted the Administration entry and clicked on the Advanced button.

This opens the "Advanced Security Settings for Drivers32" window. I made sure that I was on the Permissions tab in this window. I noticed that the box called "Inherit from parent the permission entries that apply to child objects. Include these with entries explicitly defined here" was checked. Again, I made sure that the Administration entry was highlighted and then I clicked on the Edit button.

This opens the "Permission Entry for Drivers32" window. I selected "this key and subkeys" from the Apply onto: drop down in this window. I then checked the Full Control check box. I clicked OK.

I clicked Apply from the Advanced Security Settings for Drivers32 window.

I clicked Apply from the Permissions for Drivers32 window.

Once I had done this a whole bunch more entries appeared in the right pane for Drivers32 including my wavemapper entry. It was there all along; it just didn't have any permissions to do anything including showing itself in the registry pane.


I exited the registry and now all my sounds are back and the volume icon is again in my system tray. Who would have thought?

Hope this helps someone else.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP