Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows Vista takes forever to shut down


  • Please log in to reply

#1
highland403

highland403

    Member

  • Member
  • PipPipPip
  • 226 posts
Lately Vista has been bogging down, so I turn off the computer and restart it. That usually helps.

BUT sometimes when I try shutting it down, I get a message that the sidebar is not responding. After I end that program, the log off and shut down procedure can take as long as 15 plus minutes.

I run Charter Business Desktop Security, so I don't think I have a virus. Can anyone tell me what's going on here and how to fix it?

Any and all help is appreciated.
  • 0

Advertisements


#2
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Same from safe mode?
  • 0

#3
highland403

highland403

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 226 posts
I never start Vista in Safe Mode, so I don't know if it has this same problem when running in safe mode or not. Although, I'm not sure if that's what you meant. Please explain.

Also, when I first posted this problem, I thought it would eventually shut down. It might have, but after about 25 minutes or so, I got fed up and shut off the computer. Then restarted it. I have only shut it down once since (last night) and it took about one minute to shut down.
  • 0

#4
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Restart computer in safe mode and see, if it'll shut down form there with no problem.
It'll help us diagnose your issue.
  • 0

#5
highland403

highland403

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 226 posts
I came in this morning and tried to shut down Vista. (I noticed that the F-Secure icon had a red X through it. F-Secure is Charter's desktop security suite.) It again took a very long time and finally gave me the error message that the sidebar was preventing it from shutting down. After exiting the sidebar, it again was taking forever to shut down and I had to turn off the computer.

I started the computer in Safe Mode several times and it shut down without any problems.
  • 0

#6
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Good :)
Now, for testing purposes, you need to do this:

Go Start>Run (Start Search in Vista), type in:
msconfig
Click OK (hit Enter in Vista).

Click on Startup tab.
Click Disable all
IMPORTANT! In case of laptop, make sure, you do NOT disable any keyboard, or touchpad entries.

Click Services tab.
Put checkmark in Hide all Microsoft services
Click Disable all.

Click OK.
Restart computer in Normal Mode.

NOTE. If you use different firewall, than Windows firewall, turn Windows firewall on, just for this test, since your regular firewall won't be running.
If you use Windows firewall, you're fine.

Try to shut down computer and let me know, how it went.
  • 0

#7
highland403

highland403

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 226 posts
I did as you said and it had no problems shutting down.

By the way, I have only found that it has this problem after the computer has been left on all night.
  • 0

#8
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
OK, now you need some time and a lot of patience to investigate possible culprit.

Go back to "msconfig" and re-enable ONE of the services, you just disabled.
Restart computer, try to shut it down.
Went fine?
Re-enable next service. Restart....and so on, service after service, startup after startup., until you find the culprit.

I suggest, you start with F-Secure.

Edited by Broni, 06 August 2010 - 02:50 PM.

  • 0

#9
highland403

highland403

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 226 posts
OK, but are you talking about what's listed in the Services tab? I didn't disable those, I just checked "Hide all Microsoft Services", which is now unchecked.
  • 0

#10
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts

I didn't disable those

You didn't read my instructions well then.
  • 0

Advertisements


#11
highland403

highland403

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 226 posts
I went back through your instructions and I'm pretty sure I followed them correctly this time. I disabled everything under the Startup tab, then went to the Services tab, checked Hide all Microsoft services and then clicked on disable all. I also have Windows firewall turned on. I restarted the computer and then shut it down and it shut down faster than it has in a long time.

Your next instructions were to start re-enabling services one at a time, beginning with F-Secure, restart the computer and then shut it down. I assume that once I re-enable a service, and if the computer shuts down ok, I should leave that service enabled and then enable another service, and so on.
  • 0

#12
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Exactly :)
  • 0

#13
highland403

highland403

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 226 posts
I have now enabled all of the services. There were no real problems with shutting down after each service was enabled.

When I tried to shut it down this morning to see if there was still a problem, it again took a long time to shut down, but it finally did shut down. The problem seems to somehow be connected with leaving the computer on all night, however, it didn't use to have this issue. I leave this computer on all night because I need to access it remotely.
  • 0

#14
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
I understand.
Under these circumstances, it won't be easy to track the culprit, or let's say it'll be time consuming.

Let's try this...
Uninstall F-Secure completely.
Install ONE of these:
- Avast! free antivirus: http://www.avast.com...avast-home.html
- Avira free antivirus: http://www.free-av.c..._antivirus.html
Make sure to turn Windows firewall ON.

The above will keep your computer safe and on the other hand we'll eliminate one possibility - your AV program.
See, what will happen.
  • 0

#15
highland403

highland403

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 226 posts
I installed Avast on August 10th and have been testing the shutdown every morning since.

I don't know what the normal shut down time is, but, to date, it doesn't seem to have any problems shutting down. It takes 1 to 2 minutes.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP