Jump to content

Welcome to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute.
Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message and all ads will be removed once you have signed in.
Create an Account Login to Account

Limited or no connectivity...the network did not assign a network addr


  • Please log in to reply

#1
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
My apologies if this should have gone into the thread already devoted to this topic, but I wasn't sure what the protocol was for requesting help.

Let me preface by saying I know very little about hooking up computers to a wireless router and computers in general. I'm having trouble getting my PC (emachines 2006) to work with the wireless router I bought. The installation of both my wireless USB adapter and the wireless router went well. My USB adapter recognizes that there's a signal and that the strength is excellent. It even tells me that it's connected to it. However, I get a message telling me that I have limited or no connectivity. The really weird part is that only a few hours ago, I was successfully navigating the internet using the wireless connection. (See, when I hooked up the router, the instructions suggested I set up the wireless router from a wired computer, by way of running a line from one of the ports on the router to my PC. After doing so, I had the USB adapter and router sync up with one another, which was successful. When I saw that the wireless signal was working, I disconnected my computer from the router and had no problems going from one website to another.) When I restarted my computer to double check that everything would be in working order when I relocated my PC to a different floor, I got the error message. I've tried a lot of things: the release/renew; disconnected and reconnecting everything (computer, modem, router); restored the router to factory conditions; netsh winsock reset catalog. I'm running Windows XP. I don't know if it makes a difference, but my IP address is listed 169.254.x.x. The router IP address is 192.168.x.x. What makes this truly exasperating is that right now, I can access the internet via the wireless router as long as I have a cable connecting one of its ports to my PC. This leads me to assume that my equipment is more or less working fine, and that the problem is something to do with the IP address. Can anyone give me some tips?

Edit: I have no recently removed any spyware from my computer. In fact, my computer had been disconnected entirely from the internet for two months up until a few days ago. My software/anti-virus/windows are all up to date. I've tried to "ping" my computer IP address but it fails.

Edited by veritas607, 26 August 2010 - 02:13 PM.

  • 0

Advertisement


#2
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
Your IP address suggests your router isn't assigning your pc a IP address and hence you cannot access the internet. Your IP address of 169.254.X.X means your pc "asked" your router for a IP address but somewhere along the lines it failed and therefore your pc assigned itself an IP address. To solve this issue you will need to enable the DHCP setting on your router (and/or ensure the correct settings are being used on your wireless connection) to enable your laptop to be assigned an IP address. Or, if you wish you can manually assign your computer an IP address. I will be happy to help further but without knowing anything about your router(make/model) I can't help. The problem shouldn't be had to fix so don't worry. Please reply with the router details and I will try and help point you in the right direction - if all else fails I'll help set up your IP address manually.
  • 0

#3
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
Thanks for your help! The router is a trendnet TEW-651BR.

Prior to reading your reply, I went into my Network Connections-> wireless network connection-> properties-> internet protocol-> properties and then I clicked the option to "use the following IP address" and duplicated the number from the router. That actually worked to completely establish a wireless internet connection. However, I couldn't navigate the internet! Every web page I tried to go to failed to connect. I didn't fill in a preferred DNS server because I couldn't find anything that exactly matched that wording on the router options. Weird: when I made that change and the wireless connection was (supposedly) working, I lost the ability to do anything online with the router plugged into my computer. Because that failed to establish an internet connection, I changed the option back to obtain an IP address automatically and am back to where I started with limited or no activity and needing to hook directly into the router to use the internet.

Edited by veritas607, 26 August 2010 - 03:06 PM.

  • 0

#4
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
I'll fill you in on the differences so you understand what is going on...

Normally when you turn your computer on it asks the router for an IP address. If the router doesn't give it one (normally becuase something called DHCP is turned off) then your computer assigns itself one so that it can still communicate with other computers on your network(but not the internet). Now there's no disadvantage to doing it manually as such so long as you enter the correct settings everything will be fine. The easiest option is to enable DHCP because then everything is automated - so this is what I would suggest. However, since I cannot see your router configuration page it is hard for me to tell you exactly what to do. Try looking to see of there is an option for DHCP anywhere. If you decide to go for a static configuration you will need the following settings. Now I can't tell you them for sure because I don't know what you have setup on your router so these may not work but I've just looked at the manual for your router and if you didn't change any of the default settings then these should work:

IP Address: 192.168.10.180
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.10.1 (This should be the address of your router)

DNS Server: 192.168.10.1

Leave "Alternate DNS Server" blank.

After you have typed these in click ok and restart your computer.

First have a look at your router configuration page by going typing 192.168.10.1 into a browser and look to make sure DHCP is enabled.

Let me know how you get on.

Edited by hendaz, 26 August 2010 - 03:30 PM.

  • 0

#5
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
DHCP is enabled. (I made the mistake when I first set up the router of trying to do too many things to increase the wireless security without understanding what I was doing and long story short, I restored the router to its factory conditions, went through the set-up again and this time (I think) just added a security password (I turned on WPA.)) I've tried to avoid doing anything with the router configuration page since getting it up and running the other day for fear of screwing something up. I just want my PC and a laptop to be able to access the network and last I checked, the laptop wasn't having any problems.
  • 0

#6
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
I tried your suggestion for a static connection and unfortunately, it failed. My computer shows that I'm connected with excellent strength, however, I can't get onto the internet because my browser fails to make any connection. Is there something I need to change with my browser (firefox) or is there something else I need to do with my computer settings?
  • 0

#7
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
If your computer is connected to the router but has no internet access then that indicates that either the default gateway or DNS Server address has been entered incorrectly. These two values should be the same in your setup. Please check you have entered these correctly and are both the address of the router. To help check what is wrong do the following:

Go to start -> type cmd in the search box at the bottom (or click 'run' if using win. XP) -> hit enter

A command prompt window now appears. Type the following (enter the first line then wait for the computer to stop process the command before continuing):

ping 192.168.10.1

ping yahoo.com

ping 72.30.2.43

Then reply with whether or not each of the tests is a success or failure. For example, you should reply saying ping 192.168.10.1 - SUCCESS (OR FAILED), ping yahoo.com - SUCCESS (OR FAILED) etc..

The screen-shot below shows what a successful ping will look like:

ping success.gif


This screen shot shows what a failed ping will look like:

ping fail.jpg

As you can see the successful ping reply's with a reply and failed ping says timed out.

Please post back your results and I'll see whats up.
  • 0

#8
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
When hooked up to the router directly, all three pings were successful. When both wireless and cable are hooked in and operating, all three pings are successful. When left to just the wireless connection (which shows that I'm connected) all three pings fail.

On the router management page, there is a section under "routing" that says "static" which is completely blank. Don't know if that should contain the other information or not.

Edited by veritas607, 27 August 2010 - 05:30 PM.

  • 0

#9
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
Ok, thanks for that info. Basically, from what your saying wired works fine (Having both wireless and wired connected at the same time will mean only the wired connection is being used) but wireless isn't. The test were to see what exactly the problem was and since the wireless failed all three it shows it isn't communicating with the router - that's the problem. We assigned the default gateway etc with the address that I could only guess was the router. This appears not to be the case. If you could connect using a wired connection then do the following:

Go to start -> type cmd in the search box at the bottom (or click 'run' if using win. XP) -> hit enter ->type ipconfig /all -> print screen the full output -> paste it into paint or something -> save it and upload it.

The output should look something like this:

Windows XP Professional-2010-08-22-11-27-04.png
  • 0

#10
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
Sorry this doesn't look exactly like your example, but it's all the information:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Jamie.EMACHINES_2006>ipconfig/all
Windows IP Configuration
Host Name . . . . . . . . . . . . : eMachines-2006
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hsd1.pa.comcast.net.
Ethernet adapter Wireless Network Connection 4:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : NETGEAR WNA1100 Wireless-N 150 USB Adapter
Physical Address. . . . . . . . . : 00-26-F2-51-4E-87
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.10.180
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.10.1
DNS Servers . . . . . . . . . . . : 192.168.10.1
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . : hsd1.pa.comcast.net.
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 00-40-CA-91-45-DF
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.10.106
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.10.1
DHCP Server . . . . . . . . . . . : 192.168.10.1
DNS Servers . . . . . . . . . . . : 192.168.10.1
Lease Obtained. . . . . . . . . . : Saturday, August 28, 2010 10:15:29 AM
Lease Expires . . . . . . . . . . : Saturday, September 04, 2010 10:15:29 AM
  • 0
<

Advertisement


#11
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
Thanks for that info. From the information given I can see that the details I gave you were in fact correct and you have entered them correctly. However, your wireless adapter can still not communicate with the router and this is what your problem is. This is more than likely a security issue related to some setting on your router. When connecting through a wired connection your computer can communicate this means your computer and router are both fine. However, a wired connection isn't affected by wireless security issues as you have a direct connection. I suggest you check your router settings to make sure you are allowing your laptop to connect wirelessly. Ensure what ever security your using is supported by both router and laptop and that you have in fact entered the security key correctly on your laptop. Once you can successfully ping 192.168.10.1 wirelessly then you know your adapter is in fact communicating with your router. If this ping test fails then your laptop is not communicating with your router and so you will not be able to access the internet.
  • 0

#12
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
After entering the proper pass code, laptops don't have any problems getting onto the internet. It's the PC that's having problems. The authentication type is currently set to WPA but I thought I read somewhere that some computers (older ones maybe?) aren't able to handle WPA so they run WEP. By changing that setting, would that help or won't it make a difference?

And just to make sure we're on the same page, basically, I just have to play around with the security settings ?
  • 0

#13
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
I'm a bit confused with your last post. From what I can tell you re-entered the pass code for the router onto your laptop and now it can access the internet fine. Not sure what you mean by the pc bit. However, to fill you in on security. There are three types of authentication for wireless security WEP, WPA and WPA2. WEP is the oldest standard and is in fact now no longer a secure means of securing a wireless network. WEP keys can easily be cracked and so I wouldn't suggest using it. WPA was the next standard and is still a good way of securing a wireless network (When used with a min of around 10 characters for the pass code). Anything that could use WEP should be able to use WPA with an upgrade of some kind. WPA2 is the latest security standard and so is the recommend way of securing a wireless network. However, not all devices may be compatible with WPA2 and in that case WPA is the recommend alternative. Let me know what issues your having and I'll see what I can do.
  • 0

#14
veritas607

veritas607

    New Member

  • Member
  • Pip
  • 8 posts
Sorry for the confusion; I'm trying to set up one laptop and one PC to be able to access wireless internet. The laptop has had no problems...it's my PC that is having all of these difficulties. You've mentioned laptop a few times and I was trying to clear up any confusion as to what device I'm having troubles with. Obviously I did a bad job of clearing up the confusion!
  • 0

#15
briankerrys47

briankerrys47

    New Member

  • Member
  • Pip
  • 4 posts
Hello just reading this post ,I am having simliar probs with my laptop w/less conn, both my desktops are ok also my Ethernet cable is ok with laptop,it won't let me online when wanting to use W/less there is no Licence details showing, all other settings are there!! If I have windows auto config then I get 'Acquiring Address' but if I enter my own settings or in this case the ones shown in Post I get as far as limited/connectivity . W/Network Status tells me I am 'Connected'Support Tab shows my settings and Manually Connfigured,under the Details Tab there is no WINS server or Licence Details
  • 0

Advertisement




Similar Topics: Limited or no connectivity...the network did not assign a network addr     x


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured