Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Remote Desktop Connection.


  • Please log in to reply

#1
joesquire

joesquire

    Member

  • Member
  • PipPipPip
  • 196 posts
Hello, at the moment I am trying to set up remote desktop connection, so when I go away I will be able to access my computer from another one.

I have set myself up a dynamic dns account with dyndns.com and I have my hostname.
I have set myself up an open port which I have edited in the registry which can be accessed from outside.

Now I am trying to connect to my PC using the windows XP Remote Desktop Connection program but it isn't happening, I have a spare computer which I can test the connection one and it just comes up with connection errors.

Does anyone have any ideas what I have missed.

I have a Netgear DG834G router and my ISP is AOL.
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
have you enabled remote desktop access on the "host" computer? right click "my computer" and choose properties, then go to the remote tab, then check the box to allow users to connect remotely. if you're wanting to connect as a different user than the local administrator you will need to click select remote users and add the other user(s) to the list.

also

I have set myself up an open port which I have edited in the registry which can be accessed from outside.

what does that mean?
  • 0

#3
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
Yes I have enabled remote desktop access, on all the computers I wish to use.

Quote
I have set myself up an open port which I have edited in the registry which can be accessed from outside.

what does that mean?

The reply to the above is that I have changed the default Remote Connection port for something that I can remember easily.
  • 0

#4
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
you shouldn't need to "remember" the port to begin with. if you're using RDP then it handles the port assignments itself and you don't really need to muck with those settings.

so even on the lan you can't remote between computers?

what are the errors that you're getting?
  • 0

#5
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
Well i'm trying to access my computer using my dynamic dns host name

like... ******.dyndns-ip.com:0000

obviously where the ** are is the name and then 0000 is the port ive opened.

am i not doing this right?

but doing it that way the error i get is:

This computer can't connect to the remote computer.

Try connecting again. If the problem continues, contact the owner etc etc
  • 0

#6
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
that would be how you would do it from outside (once we verify that everything is working inside)

from the LAN you need to either put the computers LAN IP (to find this go to the computer you're wanting to connect to, press start, then run, then type cmd and press enter, then type ipconfig and press enter, the ip address will show on the screen) or the computers host name
  • 0

#7
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
i did ipconfig and next to the ipaddress it has 192.168.0.2, because i'm behind the router, i put that address into the RDC "Computer" box and it comes up with the error just like before
  • 0

#8
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
just an update i did 192.168.0.2:port and it logged on so far, and it asked me for a username which i put in, and i dont have a password, and it says cant connect due to user restrictions
  • 0

#9
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
another update, sorry

i put in 192.168.0.2:port
i created a password for my account, and i managed to log on ok, so it works ok on the LAN
  • 0

#10
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
alrightie....then we've confirmed that it works from inside when y ou do it correctly.


now to the settings on your router. did you set up any NAT rules in the router to allow for the outside connection to be directed to the inside computers?
  • 0

Advertisements


#11
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
All I have done on the router is:

Added an outbound service for the preticular port - under firewall rules
Added an inbound service for the preticular port - under firewall rules

Added a services for the preticular port - under services

Added my Dynamic DNS account to the router too, with the host name, user name, and password

Edited by joesquire, 23 September 2010 - 08:02 AM.

  • 0

#12
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
that should be pretty much what you need to do (not knowing exactly what router you have i can't give specifics). you need to try to get to your connection from outside of your network now to see if it's going to work. this is where you'd use your dyndns address
  • 0

#13
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
I have a Netgear DG834G router.
  • 0

#14
joesquire

joesquire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 196 posts
Also in RDC what sort of thing should i be typing in under "computer" i've tried it on my other PC with
*****.dyndns-ip.com:port
but it doesn't work with that
then i even tried it with
ipaddress:port and it still didnt work
  • 0

#15
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
this is from outside correct?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP