Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Lenovo T60 battery issue


  • Please log in to reply

#1
shutterbug4it

shutterbug4it

    Member

  • Member
  • PipPip
  • 25 posts
Hi,

Hope I am not posting this twice as my previous topic got lost.

Any way,..my T60 battery is shown in the CONTROL PANEL as having a 100% charge but the icon on the bottom of my screen is blinking fast yellow and the Lenovo manual claims it is at a critical 5% or less charge. When I inplug the power cord the laptop shuts off in the blink of an eye indicating no back up power from the bat.

I read an article, not on this site, that the author claims in previous Lenovo models that a fuse might be blown and soldering a new one might be in order. That is beyond my capabilities. Any suggestions as to what I can do? Oh, the charger cord is green but without a second power cord I can't tell if that is the culprit. I could beg, borrow or steal on maybe to test the cord but I think that is not the issue.

Any thoughts?

Thank you in advance.

Old Guy
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP