Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unable to connect my wireless Samsung SCX-4623FW printer


  • Please log in to reply

#1
computer1210

computer1210

    Member

  • Member
  • PipPip
  • 24 posts
I just purchased this Samsung SCX-4623FW printer. Using the installation CD, the programs were loaded via a USB cable connected to my desktop that is running on Windows 7. That's fine and it works when connected with the cable. However, when I go to the next step to install the printer to the wireless network router, this is where I have problems. The overall instructions given is connect the printer with the USB to the computer, run the installation CD, and when complete, unplug the USB cable and the printer should now be good to go wirelessly. The problem I get stuck on is after I select my network name, I enter my WPA shared key password. However, I keep getting an error message after it tries to connect saying "Connecting Failure - Invalid Security". I know this is the correct password since my other wireless devices are able to connect using this same password. I've also double checked the caps lock and num lock buttons too. I've even shut down my devices and tried again several times, but the same error result. I can't seem to get past this step. I've even changed my network name and password and re-tried, but still no luck. I contacted the Samsung support line and they said to just follow the CD step by step instructions which I am doing. Their only solution was that it's my routers fault, but all my other wireless devices work fine.
  • 0

Advertisements


#2
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
Just a thought, have you check if your firewall is permitting the connection to your printer.
  • 0

#3
computer1210

computer1210

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
Thank you for your suggestion Alzeimer. I went to my Norton Anti-virus program and temporarily turned off my firewall protection, then tried the installation again, but no luck. I still get the same error message of it not accepting my network password. Is there another way of turning off my firewall?
  • 0

#4
Sungroupie

Sungroupie

    New Member

  • Member
  • Pip
  • 2 posts

I just purchased this Samsung SCX-4623FW printer... The problem I get stuck on is after I select my network name, I enter my WPA shared key password. However, I keep getting an error message...


I have a somewhat similar problem with this machine. After I enter the password, the Wireless Network Setting Confirm screen comes up and then the installation crashes: "Printer S/W Main Installer has encountered a problem and needs to close."

I've run through the steps several times and the same thing happens each time. I checked the FAQ and found no mention of a similar issue.

Tech support is a joke. Their phone lines and "live chat" are only open between 11 pm and 8 am Eastern time. I sent them a detailed e-mail two days ago and still have no response.

I'm wondering if you ever got your wireless up and running and if you ever received any reasonable assistance from Samsung?

Anyone have any ideas on resolving my installation problem?

Thanks.
  • 0

#5
computer1210

computer1210

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
No, I haven't been able to connect my printer wirelessly. I gave up and it can only be connected to one computer with the USB cable. I spent many hours on the phone with Samsung support and finally sent to higher tier support supervisor. Their final word..... It's not their printer that has problems, it must be my router that is the problem and to contact my router manufacturer. So, it basically Samsung passing on the blame and no help from them. I went through the installation steps over and over again but it's still not working. I called the router manufacturer for their support and no errors with the router since all my other devices that use the router signal are all working fine.
  • 0

#6
Sungroupie

Sungroupie

    New Member

  • Member
  • Pip
  • 2 posts
Sorry to hear you were unsuccessful in setting up your wireless connection.

After hours on the phone with techs on two different continents, the long-distance diagnosis on my machine is a faulty wireless card. Yesterday I dropped off the printer at a local computer shop that handles Samsung warranty work. Quite a hassle considering it's a 90 minute drive round trip and I'm without a printer for a week or more. Wondering if you may have a bum card as well? I'll keep you posted.
  • 0

#7
MAX7000

MAX7000

    New Member

  • Member
  • Pip
  • 1 posts
HI guys, same problem here, change ur wifi security to WEP-64 bit and it will work
  • 0

#8
tjrplumbing

tjrplumbing

    New Member

  • Member
  • Pip
  • 1 posts
I have just wasted 7 hours of my life changing re changing IP addresses setting up new printer drivers deleting reinstalling, connecting the wps, getting network failure messages, resetting my router and swearing, I have finally sorted it, so nobody else nearly throws their printer out of the window follow these instructions

connect your printer using wps button (on the printer), it will say connect to AP and start a countdown of 2 mins, if you have no AP button on your router, open your browser and type in your IP address into the address bar (insert username + password) and click on add WPS client (follow instructions)

The printer should then say connecting and get a steady blue light for wireless (printout a network config to make sure that the printer has connected to your SSID)

This frustrated me because I thought I was now connected but its sneaky... I still couldnt print naff all this was 3 hours in and so then I started adding printer drivers because logic dictates i need a network driver not USB driver but alas I was hitting dead ends I told you it was sneaky...........

EUREKA.... Go to samsung website and download the universal printer driver follow on screen instructions make sure you do not add the USB port printer when the printer list appears

im now printing wirelessly
  • 0

#9
Dontknow2013

Dontknow2013

    New Member

  • Member
  • Pip
  • 1 posts
Thank you and appreciate your information about Samsung Printer's Wireless connectivity.
It connected in few seconds...Thanks again.
  • 0

#10
LAJoanna

LAJoanna

    New Member

  • Member
  • Pip
  • 1 posts
I am soo close to having my issue fixed - hoping its your fix. I need some clarification on what exactly to do....i have spent hours installing and uninstalling.

Do you mean connect printer to computer or router?
what is AP?
I do not have an AP button on my router....
super confused.

connect your printer using wps button (on the printer), it will say connect to AP and start a countdown of 2 mins, if you have no AP button on your router, open your browser and type in your IP address into the address bar (insert username + password) and click on add WPS client (follow instructions)

The printer should then say connecting and get a steady blue light for wireless (printout a network config to make sure that the printer has connected to your SSID)
  • 0

#11
Ricky Martin

Ricky Martin

    New Member

  • Member
  • Pip
  • 1 posts
You will need a little networking knowhow to get your Samsung setup wirelessly. It doesn t appear the control panel gives you the option of lower case letters. I first wire connected the printer to an open port on the router. When the connection was established I printed out the network settings in order to obtain the printer s wired IP address. I opened up my browser and typed in the IP address (eg. 192.168.1.x) which connected me to the network interface on the Samsung printer. From there I clicked Network > Wireless and was able to find my SSID and enter in my password (which included upper case, lower case, and numbers.) I removed the wired cable from the printer and router and the printer was able to establish a wireles connection.
 
Source(s):

  • 0

#12
komlos

komlos

    New Member

  • Member
  • Pip
  • 1 posts
In my case the solution was to disable Wi-fi Direct. You don’t have to change network security mode.
 
Also make sure your wireless network you want your printer connected to is not the latest 5 Ghz ac type. The printer is not compatible with this, only with the somewhat older b/g/n type. In your router admin try to set the wireless mode to “b/g/n mixed”.
 
Steps:
 
- Connect your PC/Mac to the printer with USB cable.
- Install Samsung Easy Printer Manager on your Windows/Mac: http://www.samsung.c...skp/faq/1052784
- Disable Wi-fi Direct in Network Setting tab in Easy Printer Manager. If you don’t see the Wi-fi Direct setting under Network Setting just try to scroll down the page. 
- After disabling Wi-fi Direct, hit the wi-fi  “Wizard” button on this same page, right above the Wifi Direct section, and go through the wizard. Make sure you select the same wifi network your computer is on. That’s it.
 
=================================================
 
Printer: Samsung M2026W laser printer with wifi support
PC: MacBook Pro with OS X 10.9.
Router: TP-Link Archer C5 (2.4 and 5 Ghz band at the same time)
Wireless security: WPA2-Personal/AES

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP