Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unpredictable Black Screen


  • Please log in to reply

#1
Unworldly

Unworldly

    New Member

  • Member
  • Pip
  • 2 posts
My display randomly shuts off while the computer keeps running, basically I get a black screen. This was only happening when using games like World of Warcraft and Sims, but now after a OS restore the black screen shows up while doing normal web browsing.

Computer Specs:

PROCESSOR*
Intel® Core™2 Duo Processor T7350
OPERATING SYSTEM*
Genuine Windows Vista® Home Premium (SP1, 64-bit), Genuine Windows Vista® Home Premium (SP1, 32-bit)
GRAPHICS ENGINE*
NVIDIA® GeForce® 9700M GTS
GRAPHICS MEMORY*
2303MB total (64-bit): 512MB GDDR3 discrete memory + up to 1791MB shared memory w/NVIDIA® TurboCache™ technology

Memory and Storage
MEMORY*
4GB PC3-8500 DDR3 1066MHz SDRAM
HARD DRIVE*
200GB HDD (7200rpm)
OPTICAL DRIVE*
DVD-SuperMulti (+/-R double layer) with Labelflash™ drive

Audio and Video
DISPLAY SIZE*
17.0" widescreen
DISPLAY TYPE*
WXGA+ with TruBrite® Technology
DISPLAY RESOLUTION*
1440x900


  • 0

Advertisements


#2
Jordi Ruiz

Jordi Ruiz

    Member

  • Member
  • PipPip
  • 24 posts
Hello,

If you perform a system restore and this not works, try to update your graphic driver, could be an incomaptibility with your actual driver and Vista.
  • 0

#3
Unworldly

Unworldly

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
OS restore has been performed and the latest video drivers have been installed, problem still persists.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP