Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

video card issues


  • Please log in to reply

#1
executioner

executioner

    New Member

  • Member
  • Pip
  • 6 posts
ok guys i recently replaced my old radeon 7500 with a Chaintech fx 5700
its obviously a newer card and its a dx 9.0 card but for some reason i get worse fps in counter-strike and counter-strike source with it, with my old one i got constantly 99fps in cs 1.6 and in source i got somewhere from 60-30
with my new one i get 60-30 in 1.6 and 45-10 in source
does anyone know what it could be?
  • 0

Advertisements


#2
executioner

executioner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
and also does anyone know if this card can be softmoded
  • 0

#3
neilp4453

neilp4453

    Member

  • Member
  • PipPipPip
  • 139 posts
maybe its been underclocked. i know wit my older card, i updated my drivers for my graphics card and gained a fps of 3. also, i know slow cpus can limit fps. are you running any new "spyware" or "adware." also, have you tested out the card enough to know if its just the slow servers or not. and it could be wit your ping too. and maybe check your settings, are they the same or put up to the highest. those should all be in check already, but you never know. other than that, i only can think of one thing. the 7500 is better than the 5700. even though the 8500 is equivalent to the 5500. besides, if you were gettin such good fps, y did you get a new card. was another game laggin.
  • 0

#4
UV_Power

UV_Power

    Member

  • Member
  • PipPipPip
  • 391 posts

Hey hey,

The exact same thing happened to me (also choppy animation, and inevitable game crash in addition to your stuff) when I first got my Chaintech 6600(non-GT) AGP 8x. I installed the drivers (71.84) from the CD that came from the company. My buddies told me that I would benefit from the latest drivers from the website (www.nvidia.com). This fixed a few problems but not all of them...

The next thing I tried (suggested by Chaintech  :tazz: ) was to roll back the drivers to version 66.93. Who has ever heard of buying a card from a company, then being told by that company: 
"Better not use the software we designed for that card, it's no good. Try using an earlier version of drivers supplied by nVidia...  " BAH!
So, I did what he said and it helped things out the most, but I still was unhappy with how choppy everything was and how games would randomly crash.

In the end (and I pray this is not true for you), I RMAed that headache and got a new 6600(non-GT) AGP 8x, from Asus. Now I am running all my games with version 71.84 drivers (from www.nvidia.com) and everything runs beautifully. No problems. No choppys animations. No stupid flashing pull-down menus. And most importantly NO MORE CRASHES....

One more thing I wanted to mention. With the 6600GT, your Power Supply should be at least 350W and >20A in the +12V rail to really see what the card can do.

There! I am done with my big song and dance. I hope this is helpful to you. Good luck. 



This is a reply I gave to someone else in response to their 6600 not working properly. I know you have a different model card, but this is to let you know my experience with dealing with Chaintech. Something to consider.... ;)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP