Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Remote Desktop Connection keeps failing


  • Please log in to reply

#1
Ender2

Ender2

    New Member

  • Member
  • Pip
  • 1 posts
First and foremost let me say that I have a B.S. in Computer Science and am currently working on my M.S. in CSCI. I am therefore adept in many programming languages as well as hardware and networking concepts so please be considerate of this when offering help...

The setup:

I have 3 computers in my home. A Desktop [Windows 7 x64](Ender-Desktop), a Laptop [Windows 7 x32](Ender-Laptop), and a Netbook [Windows 7 x32](Ender-Netbook) the names of the PC's are in parenthesis and the respective operating systems are in brackets.

What DOES work:

Ender-Desktop WILL RDC to Ender-Netbook.
Ender-Laptop WILL RDC to Ender-Netbook.
Ender-Netbook WILL RDC to Ender-Laptop.

What DOESNT work:

Ender-Desktop WILL NOT RDC to Ender-Laptop.

The Symptoms of the problem:

RDC connects just momentarily and then displays "Windows Remote Desktop Connection has stopped responding.", if I choose to Debug in Visual Studio, I see countless access violation error (I can post VS's disassembly code if anyone wants to pour over it.) If I refuse to debug visual studio and refuse to close the program after roughly a minute my computer slows to a literal crawl... ie the computer displays input at the rate of about 1 ascii character per 7 seconds suggesting that there's some sort of infinite loop that's just destroying my CPU after the connection is established.

What I've tried:

1.) Assigning Static IP's to all machines which yield no difference than DHCP managed IPs.
2.) Using Computer Names instead of IP's.
3.) Disabling all of the "Experience" settings inside of the RDC client on Ender-Desktop.
4.) Unregister and re-register mstscax.dll: and delete bitmap cache files inside the Terminal Server Client folder.
5.) Check every possible network settings to verify Ender-Netbook and Ender-Laptop are identical (since I can RDC to the netbook but not the laptop. Windows Firewalls are off on both of them, Advanced sharing settings are identical and of course, Remote desktop is enabled identically on both machines.


My Deductions about the problem...:

The problem isn't the initialization of the connection. The connection is established, and even authenticated. I noticed that when Ender-Desktop RDC's Ender-Laptop that it logs out the current user of Ender-Laptop even though immediately afterward it crashes on Ender-Desktop. I am out of ideas here but am entirely devoted, if for nothing else to find the root of this problem.

In Summary : My Desktop PC will RDC to a portable computer running W7x32 and will NOT RDC to an identical other portable computer, though the portable computers can RDC to each other.

Furthermore: recommending other software is a nogo for this thread. I plan to host websites from the Laptop and require the ability to remote into it without ever having to touch it (plus the screen is nearly broken off.)
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP

Furthermore: recommending other software is a nogo for this thread. I plan to host websites from the Laptop and require the ability to remote into it without ever having to touch it (plus the screen is nearly broken off.)

well, you could use VNC instead of RDC but that's neither here nor there


i've seen some similar issues here at work with XP, and they all ended up being related to the graphics driver on the HOST machine. an update of the drivers typically solved the issue for me. the only other time that i've seen this particular symptom was when i had the /3g switch in the boot.ini of a cad computer.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP