Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

3 options while starting comp


  • Please log in to reply

#1
inite

inite

    Member

  • Member
  • PipPipPip
  • 409 posts
I've just reformated comp and somehow i've this new thingy. Whenever i start comp, i'll be given 30 seconds to choose which os i wanna start windows in. In the past i do not used to have these options. Furthermore, these 3 options are exactly the same.

Im wondering if the additional 2 OS will cause my comp to be laggy, or take up significant spaces, if so, is there a way i can remove the other 2 os so i just start with a default without having to wait 30 seconds.
  • 0

Advertisements


#2
back2killah

back2killah

    Member

  • Member
  • PipPip
  • 34 posts
On your C: drive is a file called boot.ini. You can edit this and remove the extra options. I recommend you make a copy of the boot.ini file to another location just in case you accidentally remove the wrong entries.

The boot.ini file is hidden, so you may have to go into Tools -> Folder Options to show hidden files. It is also read-only, so make sure you uncheck the read-only box in the file properties before deleting the extra/redundant entries (otherwise you won't be able to save your changes).

Sample boot.ini file:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Find the option under [operating systems] that matches the default and delete the other entries (if they're just duplicates, delete all but one).

This should take care of your problem.
  • 0

#3
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
ok, but does that normally take up alot of space or lag the comp somehow?
  • 0

#4
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
best post your boot.ini here for someone to look at
  • 0

#5
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
hmm, may i know where i can get the infos of boot.ini? tried search with "boot.ini" , cant find the file tho
  • 0

#6
back2killah

back2killah

    Member

  • Member
  • PipPip
  • 34 posts
It should be in your C:\ folder.
It is a hidden file, so you will have to change your folder view options.
Run Windows Explorer and click on Tools -> Folder Options.
Select the View tab you will see a list of Advanced Settings.
Change the one for Hidden Files and Folders to: Show hidden files and folders.

Then you should be able to find your boot.ini file.
  • 0

#7
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
hmm ya ok, i did just that and i cant seem to find the boot.ini in the C: drive. Could it be hidden in some other folders?
  • 0

#8
Guest_yezpahr_*

Guest_yezpahr_*
  • Guest
It ain't there!!?? Dzeez, then I got some idea. Open Notepad and copy this text to it (i copied from my own boot.ini)

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Then save it as boot.ini.

If it asks to replace the current file with the one you are trying to safe, say NO. because even though this one is mine, it might be wrong. Try to do F3 again and search for "boot" (without the quotes)

If it just saves it, reboot and it should be normal again.
  • 0

#9
blsimpson

blsimpson

    Member

  • Member
  • PipPipPip
  • 115 posts
the Boot.ini file is a Windows Protected File. You have to go into Tools>Folder Options>View> and untick the one that says: Hide Protected Operating System Files (Recommended) and click apply. You will now be able to see the Boot.ini file on the root drive (C:\). Now you can post it here.

Ben
  • 0

#10
Guest_yezpahr_*

Guest_yezpahr_*
  • Guest
I am curious what stuff he has there, mine is perfectly clean, don't you think?
  • 0

Advertisements


#11
blsimpson

blsimpson

    Member

  • Member
  • PipPipPip
  • 115 posts
yes, yours is clean. His prolly is too, just happens sometimes. I am sure all he will have to do is delete the two duplicates.
By the way, as long as you dont have multiple copies of the OS installed on the system, it will not slow-down or take up any room to have those in there, except the startup time it takes to choose the default OS. There are ways around that as well, if you dont feel comfortable editing the Boot.ini file.

Ben
  • 0

#12
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts

It ain't there!!?? Dzeez, then I got some idea. Open Notepad and copy this text to it (i copied from my own boot.ini)

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Then save it as boot.ini.

If it asks to replace the current file with the one you are trying to safe, say NO. because even though this one is mine, it might be wrong. Try to do F3 again and search for "boot" (without the quotes)

If it just saves it, reboot and it should be normal again.

View Post


Do not swap boot.ini files or edit them unless you know how to interpret Advanced RISC Computing (ARC) specifications.

default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS

You will render his computer inoperable doing this--you are booting from a the first ide drive on the first controller, but from the second partition on that drive,

This is NOT STANDARD.

Your boot.ini will absolutely prevent his computer from booting.

I appreciate your efforts to help, but you are someone with just enough knowledge to be dangerous--you are becoming a dangerous poster, yezpahr.

Please, read more, post less.
  • 0

#13
Guest_yezpahr_*

Guest_yezpahr_*
  • Guest
Poof! I only tell what I learn at school, I never heard about that stuff you just said: Advanced RISC Computing (ARC)

I now know, I will NOT post any help about the boot.ini from now on, because I have NO knowledge at ALL about that what you just mentioned. Thnx for warning -:zipper on mouth:- *lock on keyboard*

*edit* How come my CAN boot with those settings then (?), educate me :tazz:

Edited by yezpahr, 01 June 2005 - 11:32 AM.

  • 0

#14
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
yours boots that way because you installed windows xp on the second partition--windows can boot from any partition, though it does install some files on the first partition of the first device pointing at the windows install.

Most people have a single drive with a single partition.

Your ARC path tells the computer to look in the WINDOWS directory on the second partion of the windows files--this is not common.
  • 0

#15
blsimpson

blsimpson

    Member

  • Member
  • PipPipPip
  • 115 posts
you by chance using a Dell Yezpahr? If you look at the Disk Manager, under Computer Manager, you will see that there is a small partition on Disk1, and your C:\ drive is partition 2. That is why it works for you, and will not work for him.
I also agree with Yezpahr, if you are going to tell someone they are wrong, at least explain to them why. That way maybe next time he will understand, and not give the wrong information.

ben
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP