Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

laptop crashed


  • Please log in to reply

#1
whojob

whojob

    Member

  • Member
  • PipPip
  • 30 posts
when I reinstalled windows everything went fine but now my wireless internet drivers are gone help please I have a Toshiba satellite l25-s1216 with windows xp
  • 0

Advertisements


#2
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
I take it you are using a wired internet connection?
Go HERE and get the Lan driver with the following information.

09-20-2005
LAN
Driver


If wireless then you have two choices of the drivers.

09-20-2005 Wi-Fi or 09-19-2006 Driver Wi-Fi




Please let me know which one works for you
  • 0

#3
whojob

whojob

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
no the wired connection is messed up I am using my desktop at home and I noticed that the laptop shows no modem

Edited by whojob, 12 December 2010 - 11:05 AM.

  • 0

#4
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
OK so on the page are two modem drivers also.

09-20-2005
Modem


09-23-2005
Driver
Modem


  • 0

#5
whojob

whojob

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
when I go to the device manager it says other devices and these are listed all of these have yellow ? beside them Ethernet controller? multimedia audio controller? PCI modem ? SM bus controller ? video controller?
  • 0

#6
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts

beside them Ethernet controller? multimedia audio controller? PCI modem ? video controller?


Is your Ethernet, Sound, Video and modem all built on the motherboard?
If so then what you need is most likely the motherboard chipset driver to resolve most of those issues. Since there is no motherboard chipset driver on the Toshiba site then you would have to get the individual drivers and install them.
BTW your initial post said nothing of these other missing drivers.

when I reinstalled windows everything went fine but now my wireless internet drivers are gone


  • 0

#7
whojob

whojob

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
it is my sons laptop and tats all he told me but now I have the laptop in my possession and I am able to see what it is doing. When I had a similar proble with a different pc I erased the things with the ? beside them and restarted it and it installed the drivers again at start up and it worked fine.do you think I should try that?

Edited by whojob, 12 December 2010 - 11:55 AM.

  • 0

#8
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Yes you can do that but you still need to download the correct drivers for each of those items.
Download them to your desktop and then depending on if they are EXE files or zipped files you will need to run the exe file.
FYI since you have no drivers disk for the laptop I would recommend downloading all the files on that page to a folder on your desktop.
Then burn them all to a cd and mark it Drivers for Toshiba satellite L25-S1216 so you have them for the future.
  • 0

#9
whojob

whojob

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
I deleted all these that had yellow ? beside them Ethernet controller? multimedia audio controller? PCI modem ? SM bus controller ? video controller?
and installed everything that was on the page as you said and now the only thing that show up with a yellow ? in other devices is the Ethernet controller, Is there any thing else I can do?
  • 0

#10
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Did you download the one named:

09-20-2005
LAN
Driver


This is the network driver
  • 0

#11
whojob

whojob

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
no that on is not on that page it is on the next page do I need to get that one?

Edited by whojob, 12 December 2010 - 03:28 PM.

  • 0

#12
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Yes that is your network driver.
  • 0

#13
whojob

whojob

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
thanks for all your help that fixed it everything is back up and running fine
  • 0

#14
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Congratulations whojob. ;) for a successful resolution for your issue.

You are very welcome. I'm glad we could help and please let us know how everything works out for you.
If there is anything else we can do to help please feel free to ask. I appreciate that you allowed me to assist you with your issue and for your patience.
Thank you for choosing GeeksToGo for help. :D ;)
This issue now appears to be resolved.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP