Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Small Business Server 2008 Terminal Services problem


  • Please log in to reply

#1
CalicaCJA

CalicaCJA

    Member

  • Member
  • PipPip
  • 30 posts
Hi,

I am running a new installation of SBS 2008 on a HP Proliant server.

I have two PCs running Vista Business and am trying to login to the server using Remote Web Workplace. I get the error stating that 'The Terminal Services Gateway service is not running'.

When I check the server 'Services' I see that it is not running. If I try and Start it it says 'Windows could not start the Terminal Services Gateway service on the Local Computer. Error 1068: The dependency service or group failed to start.'

Checking the dependencies, I see that 'Network Policy Server' is also not running. If I try and start this it gives me the following error - 'Windows could not start the Network Policy Server service on Local Computer. Error 0x80072740: Only one usage of each socket address (protocol/network address/port) is normally permitted.

Please help as I am not familiar enough with this software to know how to resolve this.

Thank you
  • 0

Advertisements


#2
sari

sari

    GeekU Admin

  • Administrator
  • 21,248 posts
  • MVP
CalicaCJA,

Welcome to Geeks to Go. I see you've posted this in a couple of different places - if you get help at another site, please let me know.

The first question I'm going to ask is whether you have actually enabled RWW. I believe if it's enabled then these services should be started. This link explains how to enable RWW.

I'd also like to know if you have any 3rd party software installed - antivirus program, etc. - to make sure there are no conflicts there. I'd like for you to run the netstat command, which will tell us if there are any conflicts on those ports. At the command prompt, type netstat -ano. This will provide a list of all of the processes and what ports they're using. Right click, choose Select All, then Ctrl>c to copy. Paste the results in your reply here.

Thanks,

sari
  • 0

#3
CalicaCJA

CalicaCJA

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
Hi Sari

Thanks for your prompt response. Unfortunately, I'm not with the server at present so can't carry out the test until tomorrow. I am 99% sure that RWW IS enabled, but will double check.

I will post the results of the NETSTAT tomorrow.

Thank you,

CalicaCJA
  • 0

#4
CalicaCJA

CalicaCJA

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
Hi Sari,

Sorry for the delay in getting back to you.

Yes, RWW is enabled.

The server also has Symantec Endpoint protection installed. I have run the Netstat -ano command and attached it. However it was so long that the first part is missing, so I don't know if it'll be any use.

Some more information for you - if I check in Terminal Services Gateway Manager, and check the Configuration Status, it tells me that No Connection Authorization Policies are Configured, and No Resource Authorization Policies are configured.

Thanks

Attached Files


  • 0

#5
sari

sari

    GeekU Admin

  • Administrator
  • 21,248 posts
  • MVP
I'm just answering quickly from my phone, and I need to do a little more research, but I did see a thread somewhere else yesterday in which Symantec Endpoint was causing a conflict with RWW on SBS2008. I suspect that could be the issue here. I'll post a little later when I have more information.
  • 0

#6
sari

sari

    GeekU Admin

  • Administrator
  • 21,248 posts
  • MVP
The article I found is for a different issue, so I don't think it's relevant. However, I'm still wondering if Symantec's product is causing a port conflict, as it uses port 443; this is the primary port used by RWW. Let's try a more specific netstat command: netstat -aon | find ":port number", where you would replace port number with 443.
  • 0

#7
CalicaCJA

CalicaCJA

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
Hi, thank you for that suggestion.

I will try that on Monday as I'm not at the server over the weekend.

Will let you know the results on Monday.

Many thanks

CalicaCJA
  • 0

#8
CalicaCJA

CalicaCJA

    Member

  • Topic Starter
  • Member
  • PipPip
  • 30 posts
Hi,

Have tried the netstat command you requested, results are as followsd:

>netstat -aon | find ":443"

TCP 0.0.0.0:443 0.0.0.0:0 Listening 4
TCP [::]:443 [::]:0 Listening 4

Does this help?!

Thanks

CalicaCJA
  • 0

#9
Crowbar

Crowbar

    Teacher

  • GeekU Moderator
  • 4,130 posts
I have a server at work running SBS2008, I can check any settings on there for you if needed for comparison. Not running symantec, but running trend AV instead.

Is your firewall forwarding port 443 to the server? That one got me when I first set it up.
  • 0

#10
Troy

Troy

    Tech Staff

  • Technician
  • 8,841 posts
Have you tried what the TechNet forum suggested yet?

I also have SBS 2008, mine is running fine and I haven't experienced this issue directly myself though.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP