Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

External hard drive won't show up in my computer. Help ASAP!

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 4 posts
Hi I have a seagate 1.5 tb external drive and for over a year it has had problems showing up in

my computer. It shows up in the device manager and disk management, but not in my computer so I

can't access it. Thankfully I backed up my files to another drive, before yesterday when it

seemed to go on the fritz for good. (I hope not ) Last year when the drive wouldn't show up, my

mother suggested to unplug it and plug it back it in and that would work whenever it wouldn't

show up until yesterday. I tried that several times, I changed the outlet that the plug goes

into, I uninstalled from device manager and checked disk management. Nothing! This is driving

me up a wall, because I need this drive to work and it refuses to show up in my computer, but

shows up everywhere else!

Actually I did notice something I found strange that may be of use to you guys. In device

manager the USB mass storage device had a exclamation point. Also in disk management the drive

shows up as being black and unallocated (whatever that means ) Maybe that can be of some use to

you and I hope so because I have no idea what to do.

If you can't help, please point to someone who can.

  • 0




    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
1. Unplug all your USB devices
2- Go to the device manager then:
3. Expand Universal Serial Bus controllers section.
4. Right-click every device under the Universal Serial Bus controllers node, and then click Uninstall to remove them one at a time.
5. Restart the computer, and allow the computer to reinstall the USB controllers.
6. Go back to the Device manger and see if any exclamation points.
7- Plug back your USB mass storage device and see if it installs ok or if you still see a yellow exclamation point.

If no exclamation point then go to your disk management and see if still unallocated, if yes you will need to create a new partition (format it) for that space (i am assuming like you said you had already saved the data on that drive so you have no problem erasing all the data on it).

Hope that helps.
  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
I did what you said and reformatted and it showed up for about a few mins before disappearing again! I tried to unplug it and it came back as baing unallocated like it had never formatted at all. I don't know what is going on. Can you recommend something else?
  • 0



    Tech Staff

  • Technician
  • 19,724 posts
Hi atrandom, is the drive still under warranty? If it is and you have tried formatting and partitioning it as suggested by Alzeimer but to no avail return it before it drops you in it.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP