Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

CD/DVD drive won't work after Windows 7 Upgrade


  • Please log in to reply

#1
adams0423

adams0423

    Member

  • Member
  • PipPipPip
  • 123 posts
Gateway Desktop GT5468, formerly Windows Vista 32 upgraded to Windows 7. No problems upgrading, and the DVD drive worked great through the upgrade.

After the upgrade, I cannot read any files on CDs/DVDs. If I try to launch exe files from the DVD I get:
"Windows Security: Your Internet security settings prevented one or more files from being opened."

If I put the same DVD in any other system it works great.

I've uninstalled the drive from Device Manager and let it reinstall. No problems there, but no luck either.
The Gateway site doesn't list any Optical Drive drivers or firmware on their site for this system.

The CD/DVD drive is TSSTcorp CD/DVDW TS-H652D ATA Device.

Thanks for any help you can offer!
  • 0

Advertisements


#2
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
I do not think it is your CD\DVD drive the problem but your settings:

You wrote "Windows Security: Your Internet security settings prevented one or more files from being opened."

The files are read, just windows is not opening then due to your security settings.

I am not a user of windows 7 so cannot advise you were to go to change your security settings but this is where i would investigate if i was you.
  • 0

#3
adams0423

adams0423

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 123 posts
Sure enough, in safe mode I was able to launch content on the DVD with no problem. I launched the computer in MSCONFIG diagnostic mode, and still get the same error.

Anyone know where to configure DVD security settings in 7 Home Premium (since gpedit is not available)?
  • 0

#4
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
It is not your dvd settings but your Internet Explorer settings you have to change.

Try to reset the Internet Explorer (Control Panel > Internet Options > Advanced > Reset)?

Hope this helps
  • 0

#5
adams0423

adams0423

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 123 posts
No joy. I'd tried numerous security settings in IE and then tried your suggestion, but it still won't allow me to load a DVD in normal mode. I get the same errors.

It is a shame I can't get into gpedit in Home Premium to review those settings.
  • 0

#6
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
This is a fix that helped many users with the same problem as yours, maybe it can help you

1. Create another user (admin)
2. Switch to the newly-created user
3. Run regedit
4. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
5. Right-click -> export to a public folder or root dir (C:\ folder)
6. Switch back to your original account
7. Run regedit and remove the above keys from your original account
8. Go to C:\ and run the exported .reg

Hope this will help
  • 0

#7
adams0423

adams0423

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 123 posts
Done, no change.
  • 0

#8
adams0423

adams0423

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 123 posts
Also, when I created the new admin profile, it also couldn't access the files. Not profile related. Very frustrated. I can't think of what else to try.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP