Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Winsock/Winsock2 Issue


  • Please log in to reply

#1
lkmst11

lkmst11

    Member

  • Member
  • PipPip
  • 17 posts
Hi,

A few days ago, I removed a virus on my laptop(at least part of it, enough to be able to login under normal startup). I was trying to connect to the internet via wireless and/or wired DSL to run a few more antivirus softwares to finally remove all of the virus. However, the computer is not able to connect to the internet. When using wireless, the computer recognizes the network but says "local only" and no internet. When connecting the dsl modem directly it also doesn't recognize the modem and/or router. The modem and router are working fine. I have a desktop that works fine when wired to router and another wireless device that connects perfectly fine to router. So, I am sure is not an issue with the router or the modem or the internet service.

Computer Details:
Windows Vista Home Premium
Service Pack 1
Gateway 64-bit

When I do ipconfig/all it shows the following:

Wireless LAN adapter Wireless Network Connection:
Connection-specific DNS Suffix.:
Link-Local IPv6 Address........: fe80::ad15:7169:3c1c:e1ae%11
Autoconfiguration IPv4 Address.: 168.254.225.174
Subnet Mask....................: 225.225.0.0
Default Gateway................:

Things I've tried:

1.- Ipconfig release and renew. Rrenew doesn't work. It says "An error occurred while renewing interface Wireless Network Connection: unable to contact your DHCP server. Request has timed out..."
2.- netsh reset catalog. Successfull reset
3.- regedit (checked that Dhcp Default Gateway didn't have extra lines)
4.- Manually specifying IP addresses under Network Connection Properties.

I am thinking my winsock and winsock2 registry keys are corrupted.

In advance, thanks for your help!

Edited by lkmst11, 20 February 2011 - 03:15 PM.

  • 0

Advertisements


#2
BrussleSprouts

BrussleSprouts

    Member

  • Member
  • PipPip
  • 26 posts
You could try : netsh int ip reset c:\resetlog.txt

This will reset your TCP/IP settings and place a log of the changes in the specified location. I have had this command fix several networking issues that I have run into after removing malware from machines I have worked on.

Here is the Microsoft KB article about the command if you wanted to read up on it.

Hope that helps :D
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP