Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

New Drive... Unable to Format

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Right, i've tried a few things.. So will list everything, it will be a big post. it's got me beat.
firstly, i've baught a Sata drive (500gb western digital) as a secondary storage drive
(currently have 2x drives one with windows one with data stored on it)

I've installed it, went to initialize it in Disk Management... and straight away, it's Popped up with the "Windows was unable to complete the format"
The drive currently shows up as G: (what i assigned it) It's showing as a Healthy Active Partition.
Tried to format it again in NTFS, and straight away, same problem.
I've then tried to format it using cmd prompt, and it looked like it was okay, after 1 hour... it popped up a message, the drive couln't be formatted.

Next step i thought my Sata5 port may be a problem, so i got an old harddrive out of another system and plugged it in, windows recognised it straight away, allowed me to access it.
then i thought it might be a problem with that specific drive and the Sata5 port... so i connected it to Sata3 (currently used by a dvdrom)... that worked fine.

i've took it back to the shop... They've looked at it in their machine, straight away it was recognised... So they done a quickformat, dragged a file on it to check it, and reformatted it in NTFS...

I came back home, plugged the drive in, it showed up as an active drive in my computer showed it's capacity etc... all seemed to work, until i went to access it, and it told me the file system was Corrupt. So tried again, still the same message.

Went to do Disk error check on it, and the drive data just disapeared again... (Still showing up in NTFS though but just as a blank inaccessable drive) just saying that the Drive Parameter is not available.

Tried to format it again... Now it's back in RAW mode unable to format.

Any suggestions as to what i can do? I've tried everything i know.

even tried installing an operating system on it, and this isn't having any of it. *Shrugs* In 10 years of building computers, i'm officially beat. The guys in the shop have offered me a new drive tomorow if i can't sort it, even though i'm 99% Sure it's not the drive.
Also might want to add, all my spec is in my profile, and i'm using a 1000w thermaltake PSU.

Edited by big_fella_andy, 24 February 2011 - 10:50 AM.

  • 0




    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
Did you check in your BIOS under Advanced/Onboard Device Configuration/Serial-ATA configuration if RAID is enable or disable (unless using RAID should be disable) and if enable if your Sata5 port is enable for RAID (if yes disable it).

Also when you say that when you connected your new drive to Sata3 it worked fine, did you mean that you tried to format your new drive while in Sata3 and it worked.

If yes then why don't you change your DVD-rom on Sata5 and your new drive on Sata3
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP