Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Laptop refuses to connect to home network after replacing/upgrading ro

  • Please log in to reply




  • Member
  • PipPip
  • 21 posts
Hello everyone!

I just replaced my home network's old school Linksys Wireless G router with the E2000 Wireless N Dual Band router. I have successfully connected my girlfriend's computer, Apple TV, and my Ipod Tough 4G to the network and it's all been very seamless and quite fast. HOWEVER, the device that gets the most use, my laptop, which is a 1 year old HP Pavilion running Vista 64 Bit REFUSES to connect. I can find the network, the signal strength is "Very Good" but everyone I go to connect to it and enter passcode I am stuck with a connection that is "local only" and will not access the internet. It worked fine before (albeit slow) with the old router so I'm confused as to what to try? I tried updating the Laptop's network adapter driver but it is saying I'm up to date (Atheros AR5007) and restarted the computer to no avail. Is there anything else I can try!? Thanks a lot in advance.

  • 0





  • Member
  • PipPipPip
  • 153 posts
this is an old post - but

Atheros AR5007EG & AR5007
I have recently been seeing a whole lot of problems with that adapter over the last couple months, especially with WPA(2) encryption and windows Vista.

The adapter gets an IP configuration, and shows as connected, but communication is non-existent or sporadic.

Log into the Router and disable the wireless security and see if you are now able to connect to the internet and surf OK. - Post back here if that does work or not.

In Device Manager right click on the wireless adapter and "update driver." That apparently has worked for some posters. If not, download and install the latest wireless driver from your laptop manufacturer's web site support section.

You can post the Make and EXACT model of PC here, along with the windows version you have and we can find the driver and post a link here.

On one occasion re-setting the router back to factory default and re-configuring the router settings has resolved the issue

Assuming that all this the wireless still does not connect to the internet, all I can suggest is to use wireless security of WEP or to get an external USB wireless card.
You might also bug your laptop's tech support about the problem--maybe people can put pressure on Atheros to find a fix.

Possible Solution with a Driver Update
A few posters at other forums who have the same issue have found that the driver from this site http://www.atheros.cz/ resolved the issue

I do NOT know anything about the site mentioned http://www.atheros.cz/

However, if you do decide to try the driver, please let us know the outcome

Direct link to the drivers are below

Vista 32 Bit
Although this driver has shown up in BSODs (Blue Screen Of Death) on Vista SP2 systems, usually conflicting with updated Vista OS drivers like netio.sys, tcpip.sys and other networking related drivers.

Vista 32 Bit
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP