Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Back button on Firefox not working


  • Please log in to reply

#1
Ducon

Ducon

    Member

  • Member
  • PipPip
  • 17 posts
Just recently started to have this issue when I open my homepage (forum) and choose a topic, then when I try to click "back" I cant. Button is greyed out. If I click on to some other page it starts to work, its only the first page it wont go back to. Doesnt matter where you set homepage. Also my mouse has started to do doubleclicks randomly. Anyone who could help? Using firefox 3.6.15 and Vista

Edit: Fixed,screw Mcafee addons...

Edited by Ducon, 07 March 2011 - 09:01 AM.

  • 0

Advertisements


#2
phillipcorcoran

phillipcorcoran

    Member 1K

  • Member
  • PipPipPipPip
  • 1,293 posts
Welcome to Geeks2Go!

Glad you sorted it. I won't have any Mcafee software on my machines.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP