Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Need help with home network setup


  • Please log in to reply

#1
nem3sis__

nem3sis__

    New Member

  • Member
  • Pip
  • 3 posts
Hi! (I've just registered :tazz: )

I've tried to setup a home network with the xp tutorial, but nothing happens... no networks configured. The configuration is as follows:

Posted Image

I've managed to get access to the internet by both the desktop and the laptop, but sharing files between them is a different story...

The router is a SMC2804WBR, and both computers have win xp. The laptop has SP2.

Sorry if I sound ignorant, but I've never actually done this before...

Thanks in advance ;)

Edited by nem3sis__, 28 May 2005 - 03:27 PM.

  • 0

Advertisements


#2
djgotee

djgotee

    Member

  • Member
  • PipPipPip
  • 269 posts
There can be other items inviolved, however, take a look at the following first :

Start by hooking all comps up with cat5 cables as a wired type system, then,

(this applys to 3 machines--one ME, one XP pro and one Xp home)
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.

Next, check your XP networking setup:(link outdated)

Although this link says to set netbios over tcp/ip to "default", follow the instructions below...

Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..

For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)

Client for Microsoft Networks needs to be the primary network logon for all other machines

All machines are in the same workgroup

Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP. Click Start, click Control Panel, and then click Network and Internet Connections. Click Network Connections.
Right-click Local Area Connection, and then click Properties. Click Internet Protocol (TCP/IP), and then click Properties. Click the General tab, and then click Advanced. Click the WINS tab. Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times. Click Close to close the Local Area Connection Properties dialog box. Close the Network Connections window.

Step 2: Start the Computer Browser Service Click Start, right-click My Computer, and then click Manage. In the console tree, expand Services and Applications.
Click Services. In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start. Close the Computer Management window.

and on the PRO box
disable simplified sharing

and
Run local security policy editor from control panel admin tools and set the local policy, Network Access or security options (or security options, network access): Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled
OR
on the XP machine
Start | Programs | Administrative Tools | Local Security Policy
Security options, network access--sharing and security model for local accounts
Change this to "Classic Mode - Local users Authenticate as Themselves" (as opposed to "Guest only" the default model)
this fix will be applied after a restart

If you use the second option add the username and password that you use to log on to the ME box to the XP box, so that user is on both machines, and give that user permissions to the shares

The above is only a start, other items have to be considered also, however, its a good idea to try to do these basic things first...

Edited by djgotee, 28 May 2005 - 05:06 PM.

  • 0

#3
djgotee

djgotee

    Member

  • Member
  • PipPipPip
  • 269 posts
Oh and also...:

Make sure you are logged on with user name and password for all computers, otherwise there will be authentication problems.
XP home uses auto logon as the default. The first logon is done as owner without a password. When you then setup a user account and logon, you do not get the user prompt because of auto logon. And, you are not logged on as new user, but still as owner, so you are not authenticated as expected by other computers. To resolve this, , use control panel, users and disable auto logon. Then log off and on again as the desired user.
  • 0

#4
nem3sis__

nem3sis__

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thanks a lot!! I still haven't had the opportunity to try everything. I'll say something when I've done it...
  • 0

#5
djgotee

djgotee

    Member

  • Member
  • PipPipPip
  • 269 posts
Oh and by the way....if you have a comp. with xp home on it, it is simple file sharing by default, and simple file sharing only. Sometimes on an xp home comp, the activation for the guest account gets set off. In this case, youd have to activate the guest account with :

net user guest /active:yes (in CMD)
  • 0

#6
nem3sis__

nem3sis__

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Ok, I've managed to do all of that. I have a few questions though:

1 - Once I have to de-activate the firewalls in both computers in order for the LAN to work properly, how will I be able to connect at least one of them to the internet and at the same time have them in network, safely?

2 - How can I actually do the same thing, but wirelessly for the laptop (if possible)?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP