Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

'file is corrupt' when upgrading SP2 to sP3


  • Please log in to reply

#1
Silvergirl34

Silvergirl34

    Member

  • Member
  • PipPip
  • 16 posts
Hi,

I just bought pc refurbished. XP with SP2 but I need SP3. Tried to download SP3 fomr microsoft website but 'file is corrupt' pops up when running program. It stops at i386\agentsvr.ex_

Please check HiJackthis:

Can someone please check and analyse this?

Many thanks,
  • 0

Advertisements


#2
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
Please download and run MGADiag.
  • Double-click on MGADiag.exe to launch the program
  • Click "Continue"
  • Ensure that the "Windows" tab is selected (it should be by default).
  • Click the "Copy" button to copy the MGA Diagnostic Report to the Windows clipboard.
  • Paste the MGA Diagnostic Report back here in your next reply.

  • 0

#3
Silvergirl34

Silvergirl34

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I don't know how to save it.

It is in CLP format and I can't attach that here.

Any help how can I copy that diagnostics?

Thanks
  • 0

#4
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
You simply click copy on the report. You then right click on the post reply here on Geeks and click paste.
  • 0

#5
Silvergirl34

Silvergirl34

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
Oh, ok.
Got it. Anyway when I have checked system information under system properties/general now it says SP3. Could that be complete even the run stopped halfway? thanks

Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->
Validation Status: Genuine
Validation Code: 0
Cached Validation Code: N/A
Windows Product
Windows Product
Windows Product ID:
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 5.1.2600.2.00010100.3.0.pro
ID:
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered, 1.9.40.0
Signed By: Microsoft
Product Name: N/A
Architecture: N/A
Build lab: N/A
TTS Error: N/A
Validation Diagnostic: 025D1FF3-230-1
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A
Version: N/A

Windows XP Notifications Data-->
Cached Result: 0
File Exists: Yes
Version: 1.9.40.0
WgaTray.exe Signed By: Microsoft
WgaLogon.dll Signed By: Microsoft

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-230-1

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{845CE4CE-EA0F-4DA5-9083-F170E1B62E44}</UGUID><Version>1.9.0027.0</Version><OS>5.1.2600.2.00010100.3.0.pro</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-K42BQ</PKey><PID>76487-OEM-2211906-00101</PID><PIDType>2</PIDType><SID>S-1-5-21-337701162-1925368984-696181674</SID><SYSTEM><Manufacturer>Hewlett-Packard</Manufacturer><Model>HP Compaq dc7700 Small Form Factor</Model></SYSTEM><BIOS><Manufacturer>Hewlett-Packard</Manufacturer><Version>786E1 v01.10</Version><SMBIOSVersion major="2" minor="4"/><Date>20070413000000.000000+000</Date><SLPBIOS>Compaq,Hewlett,Hewlett,Compaq</SLPBIOS></BIOS><HWID>88A633DF0184607A</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>0</iJoin><SBID><stat>2</stat><msppid></msppid><name>Hewlett-Packard</name><model>HP Compaq dc7700p Small Form Factor</model></SBID><OEM/><GANotification><File Name="WgaTray.exe" Version="1.9.40.0"/><File Name="WgaLogon.dll" Version="1.9.40.0"/></GANotification></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Licensing Data-->
N/A

Windows Activation Technologies-->
N/A

HWID Data-->
N/A

OEM Activation 1.0 Data-->
BIOS string matches: yes
Marker string from BIOS: 7619:Compaq Computer Corporation|1198C:Compaq Computer Corporation|1FFEA:Compaq Computer Corporation|B978:Compaq Computer Corporation|119B3:Compaq Computer Corporation|119B3:Compaq Computer Corporation|1FFEA:Hewlett-Packard Company|B978:Hewlett-Packard Company
Marker string from OEMBIOS.DAT: Compaq,Hewlett,Hewlett,Compaq

OEM Activation 2.0 Data-->
N/A

Edited by rshaffer61, 01 April 2011 - 05:43 PM.
Removed OS Lic number

  • 0

#6
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
Go back to Windows Update.
After the normal active X verification
click on the left hand pane - Update history - there are page numbers at the bottom of the window that opens.
When it opens it wil start with the most recent - have a look pls at SP3 bit also at the ones prededing it, particularly the failures.
Clcik on the relevant line for further info.
  • 0

#7
Silvergirl34

Silvergirl34

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
Hi,

I am sorry can you please specify the steps?

Exactly what I need to do?

Thanks,
  • 0

#8
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
I am sorry I do know what else you want me to say.
Open a browser.
If you are on IE go to the Safety tab on the lower menu bar. Click once.
On the menu that opens click windows update
Then follow the rest of my previous post.
1. Verifiy that SP3 is shown as successful and when.
2. Verify which have failed.
Post the KB number of the failed ones.
  • 0

#9
Silvergirl34

Silvergirl34

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I have checked the updates:

Security Update for Windows Media Format Runtime 9, 9.5 & 11 for Windows XP SP3 (KB978695) successful on 30th March

Security Update for Windows XP Service Pack 3 (KB973540) successful on 30th March

Security Update for Windows XP Service Pack 3 (KB952069) successful on 30th March

Windows XP Service Pack 3 (KB936929) successful on 29th March

There is NONE failed, but I'm using Firefox. Is the problem with that?

I even tried to run Ad-aware on the pc but it says agaiin the setup file may be corrupt or have a wrong password.

Now I tried run Flash Player it said completed but then when I try to watch a short video it says I do not have Flash on pc.

Could it be the hard drive? If I replace it you think it solve the problem?

Thanks,

Edited by Silvergirl34, 03 April 2011 - 01:07 AM.

  • 0

#10
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
What anti-virus is installed at this time
  • 0

Advertisements


#11
Silvergirl34

Silvergirl34

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I have AVG.
  • 0

#12
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
Ps go start, run and type msconfig
On the window that opens pls click the startup tab
Do you have this listed
agentsvr

If so please look across and tell me the rest of the entries on that line
  • 0

#13
Silvergirl34

Silvergirl34

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
No, agentsvr is not listed.

I have:

igfxtray
hkcmd
igfxpers
RTHDCPL
pdfsty
SDMSSplash
SetRefresh
RecGuard
Remind_XP
Scheduler
ACIntUsr
Avgtray
Reader_sl
AdobeARM
Ctfmon
msmsgs

Although I found something on pc looks like a spyware. Not sure though. It has a spy face and when I remove it comes back straight away.

It is C:\Windows\msagent
C:\Windows\ServicePackFiles\i386
C:\Windows\SoftwareDistribution\Download\9866fb57abcdc0ea2f5d4132d055ba4e


And when tried to run SP3 upgrade it stops at i386\agentsvr.ex

So maybe this is the problem? And how can I remove it?

Thanks

Edited by Silvergirl34, 03 April 2011 - 12:14 PM.

  • 0

#14
Macboatmaster

Macboatmaster

    7k

  • Member
  • PipPipPipPipPipPipPipPip
  • 7,237 posts
1. Go start, run, type msconfig.
Click the startup tab.
On the list of startup items
UNCHECK all items except

RecGuard
pdfsty
Scheduler
AVGtray
ctfmon.


Then click Apply and OK
Restart the computer and when a message appears regarding system configuration utility - click to check the box - do not show again.

2. Open My Computer, right click the hard drive, click properties, click tools, click error checking, click check now, click to check both boxes, that is check for file system errors scan for and attempt recovery of bad sectors. Click Start and agree to run on restart. Do so and PLEASE DO NOT INTERRUPT the process. it is a five stage check and may take sometime.


It is your computer and you may of course do as you wish., but I recommend that you do not try any other possible solutions, unless recommended here on
Geeksto Go, whilst I am attempting to solve the issue for you.

Edited by Macboatmaster, 04 April 2011 - 07:17 PM.

  • 0

#15
Silvergirl34

Silvergirl34

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
Ok, I have done what you said.

Tried to run SP3 upgrade from the same file that was already in Donwloads folder. Also tried to run Ad-aware and I have the same 'File is corrupt' message and the 'setup file may be corrupt' message.

Or shouldn't I have restart again after error disk check?

Could it be that the hard drive is faulty?

Thanks
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP