Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

mouse probelm HL2

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
This appears to be more of hardware problem, but it's only noticeable in games, so hopefully someone else has had this problem and can help me. If this needs to be moved, my apologies.
My problem is this: when pressing the keyboard, I cannot press the mouse buttons. Not that I can't physically press them, of course, but left/right clicking won't render a response. This is most noticeable, as I mentioned, in games--I recently began to replay Half Life 2, and noticed it then--I cannot move (W) and fire (left click) at the same time. I actually cannot do anything with the mouse buttons (left, right, or wheel-click) when moving (W,A,S, or D). For instance, I tried assigning the 'fire' button to right click, then moving; it didn't work. I also tried it with wheel click, same result. However, the mouse wheel, as in scrolling (in this case, through your weapons), works when moving. It's also not just the 'W' key, as I cannot left click and move backwards ('S') as well.
Hopefully that's not too confusing.

I'm using a Lenovo G550 laptop:
Windows 7 Ultimate SP1
Pentium T440 (dual-core) 2.20 ghz
2 gb RAM
No devices report conflicts; all drivers are up to date...
This problem is also noticeable in other games, such as Portal and Garry's Mod.
The USB plug-in-and-play mouse I'm using is also Lenovo; it came with the laptop. I've also tried using the mouse pad left/right buttons; the also didn't work.
I know this is a pretty bizarre problem, hopefully someone has seen it before.

Thanks in advance!
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP