Jump to content

Free help from tech experts
Welcome to Geeks to Go forums. Create an account now to gain access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing topics, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. Best of all, registration and all assistance is 100% free! This message, and all ads will be removed once you have signed in.
Sign In Create Account

Http://connect can't connect client pc to sbs2008 server


  • Please log in to reply

#1
CalicaCJA

CalicaCJA

    Member

  • Member
  • PipPip
  • 17 posts
Hi,

Can anyone help?

I have an HP Proliant server running Microsoft Small Business Server 2008.

I have a couple of laptops which were connected to the server using the http://connect command without any problems.
A couple of things that then changed was the server was given a static IP address, and the laptop hard drive failed. A new harddrive was installed with Windows 7 Pro reinstalled and now I need to reconnect it to the server.

The http://connect command does not work - it just gives the standard unable to connect error message.

I wonder if this is to do with the static IP address as this is the only thing that has changed - unfortunately I just don't understand IP addresses, DNS servers, default gateways etc!

I have tried following the solution in Microsoft support KB957708, as follows:

Use the following steps to add the correct DNS suffix within the network card dns settings of the workstation. Afterward http://connect should work successfully.
Click Start, click Run and type: ncpa.cpl and click OK.
Right click the Local Area Connection network card and click Properties.
Select Internet Protocol (TCP/IP) and click Properties.
Confirm that the IP address is on the same subnet and that the Preferred DNS server is pointing to the IP of the Small Business Server.
Click the Advanced button and click the DNS Tab.
Fill in the "DNS suffix for this connection" box with the DNS suffix name.

In order to find the correct dns suffix open a command prompt on the SBS 2008 server and type: Set Userdnsdomain

This will return the USERDNSDOMAIN=<yourdnsdomainsuffix.local>
After entering the correct DNS suffix, click OK two times and click Close.
Close Network Connections.

To test the setting open a command prompt and attempt to ping "connect". This should resolve to the ip address of the Small Business Server 2008.
Open Internet Explorer on the workstation and type: http://connect and hit <enter>

You should now get the "Welcome to Windows Small Business Server 2008"


The laptop is usually setup to obtain IP and DNS automatically and this works fine. If I make any changes to the settings I still can't http://connect, but I then also lose the internet as it changes to unidentified network.

I've typed the static IP address into the 'Preferred DNS server' and added the 'DNS suffix connection' in the Advanced properties but just can't make it work.

Would welcome any suggestions!

Thanks
  • 0

#2
Troy

Troy

    Tech Staff

  • Technician
  • 8,802 posts
Hello,

On the SBS 2008 Console, hit the Network button up the top. The Computers tab will be highlighted by default. Then over on the right you will have a link to "Connect computers to your network", follow the wizard and you have the option to put the "Connect" program on a portable USB and you can run it directly on the laptop to be joined to the domain.

But what I am worried about is why the static IP address of the server changed? Who changed it and why? I suggest you also run the "Fix my network wizard", in fact do this first before trying to join the laptop to the domain. You can find this again in the SBS 2008 Console, hit Network button up the top, and then choose the "Connectivity" tab on the right. You will see the "Fix my network" task on the right. In fact once this is run you will probably find the http://connect/ website will start working again.

Let me know how you go.

In a nutshell - the SBS server is the DNS server for the network, it is the DHCP server for the network (and DHCP should be disabled on your modem/router), the default gateway is the modem that connects to the internet. Oh and IP Addressing, hhmmmm, basically each computer must have its own IP Address so any other computer looking for it can find it. That's why the SBS server is the DHCP server, it will allocate IP addresses to devices connected to the network. For this reason the laptops (and any other device) should all be set to automatically obtain IP and DNS etc...

Troy
  • 0

#3
CalicaCJA

CalicaCJA

    Member

  • Member
  • PipPip
  • 17 posts
Hi Troy,

Thanks for your response - unfortunately I have been away over the Easter break and haven't been able to try anything at the server.

In answer to some of your comments, I did try the http://connect from a USB stick but this wouldn't work - there was an error message which I can't now remember - would have to try again tomorrow and make a note of it.

Regarding the static IP address, if I remember correctly it was suggested that we would be better off having one as we wanted to be VPN-ing into the server from home and using Remote Desktop, and so we asked our ISP to arrange a static IP for us.

I should be at the server sometime tomorrow so will try a few more things, and will keep you posted.

Thanks again!
  • 0

#4
CalicaCJA

CalicaCJA

    Member

  • Member
  • PipPip
  • 17 posts
Hi, sorry I've not been back to the server since.

I'm here now trying to connect this laptop to it again.

Having just tried the http://connect program from a USB stick this fails with the following message:

An error occurred while downloading the Connect Computer application. Please run this application again.

I have tried the Fix My Network option from SBS2008 - in fact I often have to do this - initially I assumed this was due to the generally poor network/broadband in this area, but now I think there is something wrong with the way the server is set up - probably something to do with DHCP.

We very often (several times a day) lose the internet connection here - clicking on Fix My Network usually helps but will normally come up with an error message relating to either opening ports on the router (these are open in theory as we have VPN'd into the network from home), or a message stating that the server is NOT the only DHCP server - I assume this is likely to be our main problem, as per your previous comments?

If I look at my router settings (it's a BT 2700 HGV), I see that under the Link Configuration setting, Routing is Enabled (as default). It then says that when routing is disabled, NAT and DHCP Server are disabled - is this a setting I should disable?

I appreciate your help
  • 0

#5
Troy

Troy

    Tech Staff

  • Technician
  • 8,802 posts
Yeah you want the router to be completely disabled. All it does is provide internet connectivity and porting to the server. The server takes care of the rest.
  • 0

#6
CalicaCJA

CalicaCJA

    Member

  • Member
  • PipPip
  • 17 posts
Hi,

I tried the changes to the router settings but just get more errors -

If I untick the Routing is Enabled box on the router configuration settings, I get the following error:

The selected ATM encapsulation is not compatible with this connection type PPPoE, PPPoA or Routed IPoA are not supported in bridge mode.

I then changed the 'Connection Type' setting from PPPoA to Direct IP (DHCP or Static), but get the same error and the Connection Type just changes back to PPPoA again.

Any suggestions!?

Thanks
  • 0

#7
Troy

Troy

    Tech Staff

  • Technician
  • 8,802 posts
Perhaps contact your ISP and ask them how you can disable DHCP on the router as you have a server to do this. It looks like what you are trying to do is change it to bridging mode which you don't want to do.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured