Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

BenQ 120Hz Monitor


  • Please log in to reply

#1
matt.

matt.

    Member

  • Member
  • PipPip
  • 80 posts
Howdy,

I'm trying to set this Monitor the BenQ XL2410T

I downloaded my catalyst drivers because i'm running a 6970 XFX Card.

This is my problem.

The native resolution isn't in Catalyst, it only goes upto 1680x1050, not the native 1920x1080 (i think that was the recommended)
and every time i try to switch the Refresh rate (hz) to 120, it automatically bumps back down to 1024x768 ....

Why can't i get the recomended resolution @ 120Hz?

I'm possibly missing something obvious but it's annoying me:)

Cheers

Matt
  • 0

Advertisements


#2
phillipcorcoran

phillipcorcoran

    Member 1K

  • Member
  • PipPipPipPip
  • 1,293 posts
The native resolution you need doesn't appear in the Catalyst driver probably because your graphics card does not support that resolution. It's not the driver at fault, it's the hardware (ie the graphics card).

Also regarding the "refresh rate", this depends entirely on what refresh rates the graphics card can manage.
If 120Hz won't "stick" it means the graphics card doesn't support 120Hz, or at least not at that resolution.

You may have to replace the graphics card to get the settings you need.

Edited by phillipcorcoran, 01 May 2011 - 07:20 AM.

  • 0

#3
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,008 posts
Hi matt, have you tried this below;

For some stupid reason AMD/ATI has the overscan/underscan to display less than 100% of screen size by default. Even more crazy is that since ver. 9.7 they have hidden the scaling settings deep within the CCC program.

From the CCC drop-down menu at the top-left, select 'Desktops and Displays'. This will bring up a window showing a large picture of your screen and a smaller picture of your TV on the lower-left. Right-click on the smaller picture at the bottom and then select 'Configure' from the menu that appears.

You will now be able to find a tab for scaling options with a slider bar that will let you set your desktop size to fill your entire TV screen.

Your cards Max Resolution 2560 x 1600
For help with refresh rates http://www.pagehosting.co.uk/rf/
  • 0

#4
matt.

matt.

    Member

  • Topic Starter
  • Member
  • PipPip
  • 80 posts
Hi Phil,

Yes, i've current got the resolution set over the whole screen.

In the windows display settings i can enable 1920x1080
But in CCC i cannot.

LCD Overdrive is disabled.
in FlatPanel Properties it has
Display Name: Benq XL2410T
Max Res: 1920
Max Rerfresh 120Hz

GPU scaling enabled.
I'm still stumped why CCC isn't displaying a 1920x1080 Resolution.

Refresh force, i'm running win7 will this still be ok to download and use?
  • 0

#5
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,008 posts
Hi Matt
This may help http://www.brighthub...cles/30624.aspx
Do you have the latest CCC installed? If not http://downloads.gur...nload-2687.html

Refresh force, i'm running win7 will this still be ok to download and use?

Sorry I don`t know the answer to this but hopefully one of the above will help you resolve the issue and it will not be necessary.
  • 0

#6
D35TR0Y3R

D35TR0Y3R

    New Member

  • Member
  • Pip
  • 1 posts
For 120 hz you must ensure your using a Dual Link DVI cable which will be a normal dvi but all the pins are present. The vga will only support 120 hz at a resi of 1280 so dvi will support full hd with 120hz. Since this is a normal tn with led backlighting it does not support 120hz through hdmi. Best bet is to make sure your using dvi-d, check properties in windows that the monitor is running 120hz and also change it in the ccc via display properties. Hope this helps :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP